Filters and Osnaps don't stay put

I dock my filters on the bottom left and my Osnaps on the bottom right. I’ve noticed multiple times that they trade places on their own. It’s not the result of a crash. I can place the filters on the left, close V6, re-open it and now they’re on the right side.

I’m not able to repeat that using the current in-house build.
I can arrange them like yours or any other combination, close Rhino (only one session running), restart Rhino and the tools are docked where I left them.
I can’t tell if this is a problem unique to your setup or if it has been fixed in the last week.

We should get a new WIP released tonight.
Please reply back if it’s still goofy for you.

Will do.

Hi John,

I just downloaded the new release, and the problem still exists. I can repeat it 100% of the time. In other words, they switch places with every restart.



I see in your screencast, that you are running Rhino in a fully Maximized window.
Does it make any difference if you switch to a smaller non-maximized layout?

I tried it here again and I still can’t repeat it.
I’m running two screens and my Rhino is on my Primary screen.

Also, it looks like you’re running Windows 10. Is it the 1703 version?
How many screens are you running?
What is your display adapter setup?

Hi John,

It doesn’t matter whether running maximized or not. Same thing.

My Win10 is at 1511.

I’m running 3 screens, and it is repeatable regardless of which screen I use. Also, I tested with the docked windows locked and unlocked. No difference.

I’m using an Nvidia Quadro K5000. Here is the setup:

Thanks for the details.
I don’t have a setup anything like that so I don’t know what to do next.
That looks like a pretty old build of Windows 10.

To find the problem and fix it, we have to be able to duplicate the error here on a developer’s system.

With how flaky Win10 updates have been, our IT department isn’t eager to allow updates. I’ll test on my laptop tomorrow, which has a different version of Win10. I’ll let you know what happens.

Excellent, thanks

I noticed something else about this problem this morning. If I just leave the Osnap and Filters alone, they swap places with every restart. In other words, they are where I want them on every 2nd restart.

My laptop doesn’t have this problem. Win10 is at 1703 on that machine.

I’ll have to see if I can convince IT to let me upgrade.

Is your 1703 laptop configured with multiple displays and a Quadro like the work system?
There are several variables here the the Windows version is just one of them.

Hi John,

No, it’s just a single laptop display. It has an Nvidia Quadro K2000M.

I updated to 1703 on my desktop but the problem persists. They continue to toggle back and forth whenever the WIP is opened. So I think we’ve eliminated the OS version as the culprit.

Sounds like it.
Can you try another test please?
Temporarily, reconfigure your system for just two screens with the Primary on the left.
Then do the panels swap position?
How about if the primary is on the right?

I’m trying to narrow it down and right now, you’re the only one with a system that has this bug.

Updates usually fix prior flakiness. Also, security.

Usually. But we saw an update that completely trashed madCAM. It forced Joakim to pre-release the next version which isn’t complete. I believe that was 1607.

Hi John,

I tried the combinations you mentioned, and also went down to a single monitor. Same thing. I notice my video drivers are a bit old. I’ll see if I can update that and test again.

I spoke with John Morse (the developer) this morning about this.
He says there is a file that contains the details Rhino needs to reopen these tools.
He doesn’t understand how this can happen but clearly it is.
However, we can delete that file and restart Rhino. This will make a new settings file.
It will also return everything to it’s default, original locations, requiring you to rearrange your tools again.

If you’re game, the file to delete is:

Start Rhino, rearrange your tools, close and restart Rhino and see if the panels stay put like they are supposed to.

Any better?

1 Like

Hi John,

New driver didn’t help. I deleted the file you mentioned above, rearranged my panels, and it’s still doing it. I notice that even if I dock them at the top, they still swap back and forth.

Hi John,

I just wanted to mention that this problem still exists in the beta releases.