Fillet not working for me :(

Hi so I’ve uploaded a couple images that show my fillet edge command not working too well

Anyone have an idea why ?

Any help would be much appareciated


It would certainly help if you could share the 3dm file with the problematic geometry.

One thing I can think of is that your radius is too big for the corner.
Else we need a file to check it out :slight_smile:

The fillet radius is definitely too big. Also, the surfaces may have additional complexity we are not seeing due to complicated curves used to form them.

I get better control when I join surfaces together and use the Solid→Fillet Edge command. I recommend the ‘distance between rails option’ vs. the default. During the command, you can usually get a good feel if its going to work with the preview radii.

If the fillet fails, then you know you have to either

  • use a smaller radius for the fillet
  • change the corners to be larger radii

here are some photos
in the first photo i did the same radius on both sides everywhere - it worked fine on one side and not on the other

second photo i did a larger radius on the corners than on the side/perimeter

Third photo I did smaller radius on the corners than on the sides

nothing seems to be working

And what is the distance between rails command? never used it

If you can, please post the actual 3dm file of the un-filleted object and the desired radius for the fillet - the images only show that something is not working as you expect.


Rule of Fillets:
Do them in two passes.
Big fillets first.
Small fillets last.

Its another way to control a fillet radius, at least visually.
To check it out, follow the steps I mentioned:

Solid→Fillet Edge command.
During the command, use the ‘distance between rails option’ vs. the default.

NOTE: Since I recommend a solid command, make sure that the two surfaces are joined. Otherwise, The solid command will not work.

OBJECT.3dm (34.8 KB)

A few problems:

  1. Your part is tiny; only 1.2 cm x 1.0 cm
  2. Your tolerance is not accurate enough for a small detail like the fillet.
  3. I changed the tolerance from 0.01 to 0.001
  4. You were trying to make a fillet that was too big to fit around the two small corners. Look at the two corner radii. 0.03 is your MAXIMUM size fillet that will work.
  5. I made a solid–edge fillet of 0.02 and it worked fine…


Here’s a little more visual explanation. You can think of a fillet as a two-step process, like a road and a truck. The first fillet is the road. The second fillet is the truck. If the truck does not fit on the road, it will smash through the guardrails and plummet to the valley below, exploding in a large fireball that you can see for miles.

So … build a wider road or use a smaller truck.


thank you so much for this - I was doing everything right except tolerance setting - it seems to working now.

very helpful!