Fillet not working

The fillet command is not working with simple 2d lines. Any solutions? Radius is set to 0 and both lines are on the same cplane. Since few days ago. I did run todays update so Im all up to date on Rhino 6. Im confused. Rhino 6 file attached so you can test on your end please. Thank you.fillet not working.3dm (366.9 KB)

I just tried a zero radius Fillet here on your file and it worked fine.
I can’t find anything wrong with the file.
I did select the two curves and ran Zoom Selected All viewports.

When was the last time you rebooted Windows?

Rebooted just now and still not working. Tested it on a fresh file and still same issue.

I can’t explain it.

Let me look through the Options settings.
I can’t find anything that might cause this behavior.

Hi Peter - it seems to fail if Trim=No. I’ll have to check if that is expected behavior… it might be. Meantime, the Connect command is the equivalent of Fillet with zero radius, just fyi.


I saw in the video that you have “trim” set to “no”. I’ve never been able to get planar curves to fillet if the radius is “0” and trim is set to “no”. I’m still using V5.


Wow, that solved it! Thank you.