Fillet Non co-planar Curves (3D Curves)


I’m struggling to fillet 2 curves that do not sit in the same plane.

In rhino it works using the fillet corner command, but in grasshooper the command does not crash or give any warning, but it does not fillet the corners, it only works if I put both line in the same plane.

I’ve been trying the solutions from this other thread:
[Filet 3D polyline - #2 by maje90]

Any ideas on how to make this work?

Below a file with the geometry embedded, if curves are co-planer it works, if we rotate 1 of the curves it stops working but no warning.

Fillet (10.5 KB)

It works?
Not on my installation.

The arc of the fillet “wants” to be tangent of both curves, but if the 2 curves have no plane in common it is impossible.

You would consider using blends, instead?

in rhino it works by joining both curves and doing a fillet corner

If I set the radius of the blend, it would work to I guess.
never used the blend command, going to give it a try.

How do I set the Bulge factor?

Ok the Blend Option Works,
I have less control on the radius and I dont really understand the Bulge Factor, seems to be a tangency Factore.

Attached the file

Fillet (14.6 KB)

d = the distance between the 2 curve extremities that will be made the blend curve .
For tangent continuity bulge factor (F) is the multiplier determining how much far are the control points of the bulge curve:
2021-10-23 14_59_50-Window

1 Like

Hello this also works with the Biarc component. My question is- Is there a way to precisely control the radius of the fillet? Like if I want it to be .5m etc.