Fillet edge strange failure

I want to do a fillet edge command on those edges. Why I can`t do that?


Could you help me with what is not right here to do that fillet edge command (5mm needed)? How to find that problem in 100 polysurfaces like that? Some are okay and some are not. How to correct that?

fillet_edge_error.3dm (156.7 KB)

I’ve tried to rebuild. I’ve tried to delete middle srf and do EdgeSrf again. I’ve tried to remove sides and recreate them. I don`t know what is happening here.

Thanks in advance.

When I do ctrl+shift+LMB on the edge (pick up edge) I have something like this:

It`s strange because only one edge (or two) should be there but not three. How to fix that? How to prevent that?

On one surface is even more:

you have joined multiple surfaces togehter / on top of each other
→ 6 surfaces

EDIT: this was a first guess
_explode → 5 surfaces, 2 unwanted / not needed - see below

1 Like

Could you tell me how to track things like that on a big project? I know how to track holes, lack of G1 etc. But what command will find errors like this?

ah sorry…
_explode → 5 surfaces

there is those 2 red unneeded surfaces

join the remaining 3 surfaces
_filletEdge does the job


Thanks a lot @Tom_P I panicked :slight_smile: and I haven`t seen that solution :slight_smile:

how to track ?
the selection flyout with multiple edges - where you expect one…
_what command will show the number of surfaces:

ID: 483ab138-24c7-49c4-9f49-03d2176289c4 (69486)
Object name: (not named)
Layer name: connector bars
Render Material:
source = from layer
index = -1

Valid polysurface.
open polysurface with 5 surfaces.
Edge Tally:

1 Like