Fillet edge behavious

Hi All,

Having issues filleting an edge.

Closed polysurface. The outer object fillets properly, but the inner object does not.

Any ideas?

When joining the surfaces on the inner volume, the resulting polysurface has 4 naked microedges which cause the fillets to fail.
Use “show naked edges” and “remove naked micro edges” (which is new in Rhino 6) to make sure you are left with a closed polysurface.
After that the eges will fillet just fine.

Cheers, Norbert

Hello Norbert,

I could not get the naked edges to be removed using the “remove naked micro edges” command from this model. I wonder what I am doing wrong ? Are these edges considered “micro” edges?

Thank you,


Hello - the outer faces of the object include a degenerate face - basically zero or near zero width - it looks like a line. Cleaning that up should sort out the filleting:


In fact I took that as a line, LOL.
Still joining all the surfaces leads to the naked micro edges, that need to be removed.

Yeah, the cleanest way out of this I think is

  1. ShrinkTrimmedSrf
  2. Explode
  3. Locate and delete the tiny surface
    4.Select all and UntrimAll
    5.Select all and CreateSolid


Thank you all.

I was on v5. Tried on v6 and was able to do this using the suggested commands.

Though I still don’t understand why those tiny surfaces were created in the first place, and why they were in conflict with the process.

Would there have been no way to do this in v5?

Hi Nathan - I believe the steps I described should work in V5, but I did not yet try it in 5. I guess you’re saying it did not… where does it fail?


Hi Pascal, I began trying in v6 after Norbets earlier comments, so I assumed the commands you suggested were new to v6 also.

I am new to rhino and not familiar with all the commands yet.

However the remove naked micro edges approach didnt work for me anyway. Your ‘cleanest way out’ did.

=) this never happens! But I’m glad it worked…