Files corrupted upon revert and reversion workflow

I realise I should report these issues in a separate thread … previously reported in one of the pinned threads.

I’ve used the WIP’s very reliably for at least a year, however since the implementation of the feature where we no lomger save, there are two problems.

  1. Bug: Open the file to say view or print or export to another format,
    usually with a client or the manufacturer. I exit and am forced the ‘revert’ the file, even
    though I never wanted to save it in the first place. every time the
    file will be corrupted saying invalid object in the file. luckily I keep
    backup copies of my files.

  2. Workflow: If I open a file and start making changes, I can no longer
    choose save as because the file is already saved. If I then choose
    ’duplicate’, I end up with both a copy and my original that reflect my
    changes, so my original is lost. This is a bit brutal (a bit like travelling through guandong in the rain today) because if you forget (which is extremely easy), there is no way back.

I would prefer the file does not save until I give it the go ahead.

  1. Bug: So today I was moving parts around, duplicating parts, aligning things etc. and not wanting to save the file, purely working in Rhino on a macbook with the mold maker. I tried to Undo everything to avoid the corruption problem, however when exiting I was still asked to Revert. I would assume that if all changes are undone, there’s nothing to revert.

The corruption is very reliable and reproducable so should be simple to determine if it’s a real bug or some quirk of my system. It may be amplified as I generally travel with my mac but use a desktop PC at my studio and home with Windows for various programs including Rhino. Invariably rhino for mac is for small tweaks and for facilitating discussions in my case.

  • Paul

I haven’t seen this. Can you send a file into www.rhino3d.com/upload to my attention that I can open and then revert to try and reproduce this? I know you are seeing this regularly as you described but I want to make sure we are looking at the same file and sequence of steps. I have not heard this reported either so it may be specific to your Mac or OSX version.

Hold down the Option key when in the File menu and you’ll see Save As

I am not sure what the safest way to disable versions on OSX is but @dan may know or @marlin

Hi @BrianJ I’ve disabled the autosave feature using instructions here and the problem goes away. However I did test with several files and the problem seems entirely related to just a few files I have. I will upload one now for you to look at.

Thanks for sending in the file. I tested with and without the autosave option enabled in the OSX settings in both 10.10.2 and 10.10.3 but have not been able to reproduce a corrupted file after reverting changes. I am opening the file>moving an object>closing the document and reverting changes>reopening the document. Is your workflow any different than that?

Having this issue in 10.10.3. Happened to a colleague of mine also in a previous beta. To reproduce error, you need to make quite a few changes to the file, not just moving an object. I tried the Rescue3dmFile command, but it did not detect any geometry, so I had to re-model everything from an older document.

Hi Brian,
That workflow will do it for me everytime. It’s only this file and variants of it where we branched off to try some other designs. Most other files did not cause the problem! Very strange indeed.

I don’t need to re-open the document the error occurs when I close the document, say revert, it throws up the invalid object error several times then closes. At that point the file is corrupted.

Regards
Paul

Thanks for confirming the workflow to reproduce the error, and thanks @Cesar_Niculescu for also mentioning that you’ve seen this too. @dan or @marlin do you have any ideas what might cause this?

I do not think Auto Save is the cause here. Auto Save has been in Rhino for Mac for almost four years and thus used by hundreds of thousands of users. There is something else that is the cause of the corruption.

Clicking the checkbox mentioned in the article does not turn off Auto Save, regardless what the article claims. It merely changes the Auto Save behavior. In fact Rhino for Mac internally forces this checkbox to be set when running Rhino. When the checkbox is set, Rhino (and other programs) ask if you want to revert any changes when closing a document. If the checkbox is not set, any changes you make are saved without asking.

Please post your Rhino info for your laptop: About Rhinoceros > More Info…

I wouldn’t think it’s autosave specifically as much as the “revert changes” option that seems to effect it. If I make major changes to a file and press revert, it doesn’t know how to process that correctly.

There’s something odd here. Some months back this started occurring and it ‘appeared’ to me that Rhino for Mac suddenly began asking me to revert/save files when closing them. I didn’t realise this was a mac thing and I’m very relieved to be able to turn it off globally, along with that other extremely annoying ‘benefit’ of restoring all windows when re-opening apps.

Now, since I turned this feature off in OSX, I tried to turn it back on again, however I can no longer replicated the problem as I described it above. The exact same file which was corrupting every time no longer corrupts.

It’s nearly a month ago when I reported this and I cannot recall if I had to upgrade Rhino during that time, I think I did.