3DM file corrupted on revert back changes

Hi, it happened to me 3 times last copple of months a file got corrupted upon reverting a file back after making changes. The file still has size so there is data in there, but it can’t be opened so the “browse all versions” is no option either.

I rarely use the revert option, so I just made a test file with a cube in Rhino 5.3.2 and tried to revert and it got corrupted right on the first try. I got the message “the operation could not be completed”. I tried again to reproduce this problem but then it worked fine.

Is there anyway I can still access these corrupted files to try and restore them? Would you have any idea what causes it?

I am running Sierra 10.12.6 and Rhino 5.3.2, still have 100GB free space on the HDD.

Just a guess…but I wonder if you have a disk issue.

What does First Aid in Disk Utility tell you?


Disk Utility doesn’t show anything out of the ordinary. S.M.A.R.T. verified. No problems otherwise, system is responsive, no crashes.

Hmm…I defer to a higher authority. Perhaps you might post your system info from Rhino for the developers. Good luck!

OK, thank you for thinking along.