File reads 25% and stops

unhandled

#1

Hi,
I just downloaded VisualArq to test it out. I use Rhino6.
The first file I opened worked fine, but then I downloaded a 70MB building for the project we work on and it reads 25%, stops and then ends with a “IFC Import: 0 objects imported.”

I opened the ifc file in wordpad and it reads fine, all the way to the “end”.
it’s a IFC2X3 file made from Revit.

Anything I can do?

(Edit: The system is Windows 10, dual xeon with 52GB ram and a geforce 1070, so that should not be the limit)


#2

Hm… I tried to read the first file again and got a similar error. So I clicked on the “license” tab under VisualARQ and then it checked and said that it was OK and was running in Evaluation (which is right) and after closing the dialog I was able to open first file again, but the second “stops” at 66% and freezes. Or… it uses 5% of the cpu and Rhino’s memory consumtion is slowly rising for many minutes (probably 10 or more) and then continued through the process. Regenerating graphics was also very slow, and then left the screen black for an extremely long time with no feedback, makde me wonder “did it crash?” It said it imported 10.044 objects. Total memory consumption is 9.1 GB… quite extreme for a 70MB file don’t you think?
It took over 30 minutes to read the file.

I get 1 fps in wireframe and don’t dare to change to another. Turning off a layer takes 8 seconds… quite useless to work with I’m afraid.

Oh, and PS! Please add a “Cancel” function to the importer.


(Enric Marquès) #3

Hi @Holo,

This is not normal. There should be a bug in the importer. But we have been able to open IFC files much larger than 70MB.

The bug could be in the external library we use to read IFC or in the code that converts it to VisualARQ and Rhino objects.

Can you please send the IFC files to visualarq@asuni.com so we can test here what is going on?

Enric


#4

The file can not be shared so I need a confirmation that you delete it after bugtracking. OK?


(Enric Marquès) #5

Of course I’ll delete the file after debugging it. I’ll not store it in our bugtrack and, obviously,
I’ll not share it or any part of it, in any format (model, image, etc) with anyone.

Thanks,

Enric


#6

Ok, for your information: I installed Revit and am trying to open the IFC file there and it has taken 27 minutes so far and is still counting…
So IFC might not be the solution to all our fast and speedy BIM sharing needs after all.
I’ll head to bed now and I’ll let the computer work and then we’ll see how it turns out in the morning.


#7

Geometry Gym also provides an IFC importer for rhino that you might consider testing too. Install ggRhinoIfc from http://www.geometrygym.com/downloads if you want to try.