Fatal error with Rhino WIP 2017-Aug-15 17227.14151


#1

Hi all,

This is an error report, I have just installed the above version today.
The problem is : it cant load the previous version’s (Rhino WIP 2017-Aug-8 6.0.17220.11131) .3dm file.
It omits/skips dozens of block objects, more than a half of them.
If I check block manager I have only few blocks, of course those things are missing from the projects as well, and all the layers also.
I always use “linked only blocks” and the layer style is always “referenced”.

This is an error for sure because I tried the .3dmbak file also, it failed also.
Then I uninstalled the new version (17227.14151) and reinstalled the old one (17220.11131) , and now all things work again.

I was scared like a pig I thought I’ve lost my data, and my project was damaged. No, fortunately its all good, only this new version is bugged somehow. I never had this problem with the bunch of WIP upgrades earlier.

And there is another problem, when I run the installer of the old one, it says “A newer version is already installed” - then it aborts, it doesn’t allow me to overwrite that. I think this is a bug, because I mean it, I want to restore the old one because the new one is faulty. It shouldn’t block me doing this, I know what I want, I’m not stupid.
Uninstalling-reinstalling sounds worse idea, because I don’t wanna lose any settings or data or template customization.

Regards,
Laci


(Pascal Golay) #3

Hi Laci - uninstalling and installing works fine - I do it all the time here… but so far I am not able to reproduce the problem - are all the files you’re linking 3dm files? Are some or all of them V5?

-Pascal


Ooof, rollback?
#4

Hi Pascal,

Thanks for the info, so you promise that If I uninstall Rhino, I won’t loose any settings or file.

To the other question, I checked all 41 block files, they all native 3dm type.
14 of them rhino6 format, saved with 2017-07-25
26 of them rhino6 format, saved with 2017-08-08
1 of them rhino5 format

But it doesn’t show at least 25 blocks after loading with the most recent Rhino WIP.
Th older 2017-08-08 works without any problem.

Regards,
Laci


(Pascal Golay) #5

Hi Laci - I promise that I have not had any problems doing this… =)

Thanks for the added details.

-Pascal


(John Brock) #6

Uninstalling a Windows application using the Control Panel tools, can only remove files that the original installer added and that have not been modified.
All of your settings were added or modified by you after Rhino was installed. Your models were created by you and not the installer so Windows can not remove them by uninstalling.

That said, if you run a system “cleanup” tool, manually delete folders, files, or System Registry hives, then you will very likely lose the data you are concerned about.