Fantasy slipper in SubD

Had lots of fun with SubD. My rendering capabilities are low.

11 Likes

Awesome works!

The model looks good.

For rendering, what happens if you use raytrace viewport? Or hit the render command?

When the current renderer is set to Rhino Render and I execute the render command, the render window that opens shows a black viewport.
With the “Legacy Rhino Render” it seems to work ok, unless I have at the same time a viewport in Raytraced mode, then it takes a long time for the render window to open, and sometimes Rhino crashes.

When the viewport is set to raytrace, the HUD does not show the elapsed time or the Samples count, and raytracing seems to be paused, see screenshot.
Also ViewCaptureToFile does not work for a raytraced viewport.

1 Like

Type systeminfo on the command line and send it to us here. The new rhino 7 render engine does not see to be working in your machine.

Rhino 7 SR0 2020-5-19 (Public Build, 7.0.20140.14505, Git hash:master @ 5be1555b6645f57ae8aded817179476da66181b6)
License type: Commercial, build 2020-05-19
License details: Cloud Zoo
Expires on: 2020-07-03

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 10-16-2017 (M-D-Y).
Primary OpenGL: NVIDIA Quadro K610M (NVidia) Memory: 1GB, Driver date: 9-30-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 426.25

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2019
Driver Version: 25.21.14.2625
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.20140.14505
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20140.14505
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20140.14505
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20140.14505
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20140.14505
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

The hardware is not bad, but the drivers are quite old.

Update both drivers. If you can get them off the manufacturers site that is best. But here are some on Intel’s and Nvidias site:

  1. https://downloadcenter.intel.com/product/81496/Intel-HD-Graphics-4600
  2. https://www.nvidia.com/Download/driverResults.aspx/157253/en-us

The video only has 1GB RAM. This might be a problem if the render models get large since by default Rhino 7 tries to use the video GPU. But, we can always adjust. Another option is to bypass the Video and use the CPU for rendering. But we only try that is the driver update does not help.

Install these, then run SystemInfo again and see if the dates are more current.

1 Like

THanks for your help!
The Intel page said it could not find any supported Intel drivers or software, but I found an update that did install. Updated the Nvdia driver. New system info:

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 11-15-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro K610M (NVidia) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 426.50

But I see no changes in rendering and raytracing…

Next strategy is to bypass the GPU video. Go to Tools pulldown > Options > Cycles and change the device setting from Nvidia Cuda to CPU.

Does that make a difference?

Yes, now it renders and raytracing works. Also the bumpmap is now visible. Is using the CPU instead of the graphics card a big disadvantage?
Thanks for you help!

2 Likes

Not compared to the K610M since it only has 192 Cuda cores, so your CPU will be faster.
If you had an nVidia card with 1000 or more cores it would be faster than the CPU.

In example this scene:

7 second on RTX 2070 with 2304 cores
29 seconds on CPU with 6 cores

If you have a 4 core cpu I guess it would take 45 seconds
And if your cuda cores are about the same speed as mine and you have 192/2304 cores which is 1/12 it would take 12x the time of mine which would be 84 seconds. So your CPU should be 2x faster than your graphiccard.

Also remember that 2x resolution (500x500 vs 1000x1000) is 4 x the amount of pixels and therefore 4x the time, so don’t render larger than you need and you are good to go.

If you want a simple render scene for you shoe then plese upload the file and I can put it in a simple scene and return it to you. (PM me if you don’t want to share it here, but if you share it here then others can chime in and also benefit from it later on)

@scottd are there any good reason for systemInfo to not include the CPU info?

No, not really. Systemingo was made to detect technical support problems. CPU has never been a big issue.

1 Like

Glad it is working. Now you get to see how nice rendering can get.

3 Likes

OK, I thought that was the reason :slight_smile:
Can I pitch in a wish here for adding CPU info?
It will be handy for discussing speed issues like here.
Many users don’t know what hardware they are on.

1 Like

That is very nice of you.
Here is the file of the sandal.
If anyone wants to publish it anywhere else or use it for commercial purposes, it would be nice to let me know.
I am looking forward to the results of your rendering.
SandaalForum.3dm (1.3 MB)

This is just very quick by throwing some simple materials at it. Otherwise it is Rhino 7 default.

3 Likes

Hi @PodoTools
I finally got around to set up a simple scene for you:


Rendered on a laptop with a RTX 2070, I included to time so you can compare if you like.
Viewport size is 790x503 pixels.

It’s very basic, two large rectangular lights with slightly different strength and color.
(Standar studio light setup: Key light brightest and warmest, fill light dimmer and cooler)
A curved backdrop with a default pure white material to achieve overexpsure.
Oh, and Environment is dropped down to 0.2 in strength.

It also have some simple plastic materials in it. The “white” material has a leather bump added.
I say “white” because it is slightly warm in the tone to match the purple and since nothing is puuuure white or pure black in real life, so should not be used in renderings either.

Here rendered with camera Focal blur so you know that that is an option too :wink:
It is not turned on in the file I send you, since it is a bit confusing to work with.
IF you are going to play with it is found here when perspective is the active view and NO objects are selected:
image
Toggle it on, set apparture to 20 and use the distance picker to pick a single focus point on your object. (Snap to a edge or something)

Have fun!

Holo’s Podo Studio.3dm (2.5 MB)

Edit: Oh, and I moved you logo further into the object as it was protruding a bit too much for my taste, hope you forgive my lack of respect for your copy rights :wink:

7 Likes

Nice work!

1 Like

Thanks, and thank you and @nathanletwory and @andy for making such great tools for us.
Having this as a display mode is par none and Cycles is shaping up really good for “simple” renderings like this. Great for design studies and for presentations and as a base for moving on to more complex render engines if and when the users wants to.

Setting up a scene like this takes literally 2 minutes. Drawing a backdrop curve, extrude it with Ctrl-Gumball drag, add two rectangular lights and lower environment. Then tweak strenght and color while the viewport updates instantly… Easy to do and easy to remember when done once or twice.

2 Likes