Failed to load Rhinoscript plug-in message

I seem to recall others having this happen…


I answered No and restarted Rhino, no more message and Rhinoscript appears to be loaded.

Nothing changed since yesterday, except I updated the WIP. Probably related?

@brian, this sounds like installer related issue.

Hmm, just got it again - this time nothing was installed/updated in between the previous occurrence…

i used to have this issue a few weeks ago, always when one Rhino session was already running and starting 2nd one. It went away aftet installing a new daily build of V6…

To pile it up:

might be relevant.

What version of Rhino were you starting when you saw this message?


It starts happening over here as soon as I have WIP installed, and one Rhino 6 instance is running and when I try to start another Rhino 6 (no WIP running). Then the 2nd instance of Rhino 6 fails to load Rhinoscript. Sometimes it just works, but often fails like that. I think when WIP is removed, the problem goes away.


Maybe RhinoWIP indeed plays a role. I have it installed but I don’t ever use it, I think.

:thinking:, which rhino is run when debugging a VS project?

This is annoying…


1 Like

still happening, yes. This is the reason I don’t have WIP installed anymore, until this is solved.

From what I can tell, asking around here, this is the cleanup routine…

  1. Uninstall Rhino 6
  2. Uninstall Rhino 7
  3. Open Registry Editor (in the Windows start menu, type RegEdit, then press Enter)
  4. Browse to HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0\
  5. Delete the Plug-ins folder
  6. Browse to HKEY_CURENT_USER\Software\McNeel\Rhinoceros\6.0\
  7. Delete the Plug-ins folder

Now, reinstall Rhino 6 (and the 7 WIP if you want), and it should all be cleaned up.

I’m sorry it’s so tedious. And I do not know if there is a better or more automatic way in the works.


There has to be a better explanation what is causing this.

  • Why do I need to uninstall Rhino6?

Seeing registry entry just for Rhino6 is used, a question arrises:

  • Why do Rhino6 and RhinoWIP use the same Registry entries? Same AppData/ProgramData folders?

That should be fairly easy to do with CMD/PS.
Can the installer run in silent mode? Any tutorials?

1 Like
@echo off
rem 1. Uninstall Rhino 6
cd C:\Users\peychev\Downloads\
start rhino_en-us_6.16.19169.11231.exe -uninstall -quiet -norestart
rem 2. Uninstall Rhino 7
echo wait some time for the uninstall to finish
rem 3. Open Registry Editor (in the Windows start menu, type RegEdit, then press Enter)
rem 3a. Browse to HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0\
rem 3b. Delete the Plug-ins folder
reg delete HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0\Plug-ins\ /f
rem 3c. Browse to HKEY_CURENT_USER\Software\McNeel\Rhinoceros\6.0\
rem 3d. Delete the Plug-ins folder
reg delete HKEY_CURENT_USER\Software\McNeel\Rhinoceros\6.0\Plug-ins\ /f
reg delete HKEY_CURENT_USER\Software\McNeel\Rhinoceros\5.0\ /f
echo Done!

This week I installed win10 pro in a new pc, the first program I installed was rhino 6 then vray next plugin, and later Rhino V5 with T-Splines + VSR.

Version 6 SR16
(6.16.19169.11231, 6/18/2019)

Version 5 SR14 64-bit
(5.14.522.8390, 5/22/2017)

I don’t remember upgrading anything yet, I didn’t install wip 7 either, but I received the same message today…
Last week I received the same exact message and I though that having multiple versions of rhino ( v5,v6 and wip7) could be the problem, or letting rhino install SR candidates, but now I’m a bit lost.

What should I do?

How can I prevent this happening again?


Should I paste this in CMD?

If you ask this question, I’d say don’t use the script.

FYI I followed this steps from Pascal’s comment.

  1. Uninstall Rhino 6
  2. Open Registry Editor (in the Windows start menu, type RegEdit, then press Enter)
  3. Browse to HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0\
  4. Delete the Plug-ins folder
  5. Browse to HKEY_CURENT_USER\Software\McNeel\Rhinoceros\6.0\
  6. Delete the Plug-ins folder
  7. reinstall Rhino 6

The error message disappeard.


1 Like

Hi, I just had the same issue and after searching in the forum and getting here, I solved it in a similar way:
Close Rhino 6
Run WiseRegistryCleaner ( free)
Repair the Rhino installation from the Windows Programs and Features

-I’m not sure about what causes it but a guess could be opening several rhino instances with heavy models at the same time. at least that was what I was doing when I saw the error.

1 Like