Failed to load cuda

When I tried to render with Rhino render, not legacy Rhino render, I couldn’t proceed with the work due to an error message, ‘Failed to load CUDA kernel,’ as shown in the attached image. Can you please review and let me know how to fix this?

(It seems I have two graphic cards, Display 1: AMD Radeon™ Graphics, Display 2: NVIDIA GeForce RTX 2060)

The render works properly in Rhino 7 but it doesn’t work in Rhino 8.

I would try uninstalling the denoiser and reinstalling it through packagemanager to see if that resolves.
Alternatively you can also try other denoisers that are available. If you have an Intel CPU, the intel denoiser works pretty well too.

Hello Gijs,

Thank you so much for your response. I removed all denoiser and even reinstalled Rhino 8 but I could not resolve this issue. Is there any other troubleshooting I can try?

Thank you for your help!

This message typically comes when your driver is not up to date. Please ensure you do a clean install of the most recent NVidia driver.

This error is not related to the use of denoisers.

Hi Nathan,

Thank you for your response. I’ve already checked the drivers are already up to date and also reinstalled all graphic cards again but unfortunately, I couldn’t resolve it yet. Could you share any other troubleshooting I can try?

Thank you,

Did you make sure you performed a clean installation?

Hi Gijs,

I wanted to update you on the progress after following your suggestion for a ‘Clean NVIDIA installation’. It worked like a charm, and now the render is functioning smoothly!

For anyone else encountering the ‘Failed to load CUDA’ issue, you can find the procedure here ( I hope this helps others troubleshoot and resolve similar problems.

Thanks again for your assistance!

Best regards,


I had the same problem. I just reinstalled the NVidia driver (from Nvidia) and It works fine. The Windows Update was really late.

Often Windows updates appear to mess up drivers. It is good practice to do a clean install of drivers after a Windows update, especially a bigger one.


Is there anything we can try? I was doing the Clean Nvidia Installation, In 7.0 is working fine. I was playing with the parameters, but there is not solution.

Is there any log I can check?



Are you getting in the HUD the message that cuda failed to load?

There are no logs at this time.

Yes, the same exact message.


El dc., 22 de nov. 2023, 12:51, Nathan ‘jesterKing’ Letwory via McNeel Forum <> va escriure:

If you paste the results of the Rhino command _SystemInfo we can maybe help diagnose the problem.

Sure! :slight_smile: Thanks

Rhino 8 SR0 2023-10-31 (Rhino 8, 8.0.23304.09001, Git hash:master @ 20e15cf9bd66e6676f849f22e485cb3e82a8beac)
License type: Not For Resale Lab, build 2023-10-31
License details: Cloud Zoo

Windows 11 (10.0.22635 SR0.0) or greater (Physical RAM: 32Gb)
.NET 7.0.11

Computer platform: LAPTOP - Plugged in [93% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 3-17-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.15
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\RhinoArtisan 5 for Rhino 8\Artisan.rhp “RhinoArtisan”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Update your driver to the latest (with clean install), these are a year old. Then try again, please.

1 Like

HI Nathan,

It is working great! It seems it wasn’t updating the existing. Just a point for other Rhino users, when you installing the NVidia driver, there is the Express and Custom option, check the custom option, there you can check “Clean installation”. I didn’t realize it this option was there!