Failed to load CUDA kernel in Rhino 8

I recently installed Rhino 8 (8.4) on one of my laptops and noticed rendering was super slow. Checked the render device settings. Here is what’s in the error log:

Failed to load CUDA kernel from ‘C:\Program Files\Rhino 8\Plug-ins\RhinoCycles\lib/kernel_compute.ptx’ (Unsupported PTX version)

GPU: NVIDIA RTX 2000 Ada Generation Laptop GPU

I upgraded to the latest NVADIA driver but no luck.

Any ideas?

Thanks!

Jun

Please run the Rhino command _SystemInfo and post the result in a reply.

Hi Nathan,

Results:

=============================================================
Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Commercial, build 2024-02-13
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.16

Computer platform: LAPTOP (Hosting Remote Desktop session) - Plugged in [100% battery remaining]

Standard graphics configuration.
Primary display: Microsoft Remote Display Adapter (Microsoft) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).
> Remote Desktop display device with 16 connection(s)
- Windows Main Display using connection #0
Primary OpenGL: NVIDIA RTX 2000 Ada Generation Laptop GPU (NVidia) Memory: 8GB, Driver date: 4-18-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 528.95
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 6-15-2023 (M-D-Y).
> Integrated graphics device with 0 adapter port(s)
- Using a remote connection

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-18-2023
Driver Version: 31.0.15.2895
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8188 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

This is not the latest driver for your RTX 2000 Ada gen. Your currently installed driver is almost a year old. At the moment the latest driver would be NVIDIA RTX / Quadro Desktop and Notebook Driver Release 550 | R550 U3 (551.61) | Windows 10 64-bit, Windows 11 | NVIDIA

When you do the driver installation make sure you pick advanced/custom installation type and check the clean installation checkbox.

This will ensure you have definitely the latest driver properly installed. Once you have done that Rhino 8 should be able to compile and load the CUDA kernel correctly.

I would suggest to also update to the Rhino 8.5 service release candidate, because it has some important improvements for the CUDA kernel handling. You can do that by going to Tools, then to Options and Updates and Statistics. Change the release frequency to Service Release Candidate, then click on Check Now… . Download the Rhino installer from the link shown to you in your browser and install that.

Installed the “real” latest driver and got it working.

Thanks!

TIP: do not assume what comes first googling is the real thing… :innocent:

1 Like