Raytracing CUDA kernel error

Hey there,

I am a new user to rhino. the version i am using is rhino8.
The software runs fine on my notebook, beside a few crashes but i have a problem with raytracing.
When i switch to raytracing mode i get the following error:

I can overcome this issue when i change my render engine in options to my CPU, but i would like to use my graphics card for rendering. I also tried updating my GPU drivers, having no results.
With my graphics card selected the raytracing view looks like this:

Can someone help me to solve this issue to use my graphics card as render engine for raytracing?

Hardware list:

CPU: 13th Gen Intel(R) Core™ i7-13700H
GPU: NVIDIA GeForce RTX 4060 Laptop GPU

Best regards,
Nikolai

Hi Nikolai,

install the latest NVidia-driver, then it should render. Here more details:

Cheers

Michael

Hey Micheal,

Thanks for your suggestion, I tried performing a clean installation of the latest NVidia-driver after deleting all old ones and files related to them. I even wiped the registry.

Now i dont get the error message from above anymore, but rhino doesn’t respond anymore after switching to raytracing when my graphics card is selected as render device. Also the information bar where i got the error, still stays orange.

Maybe youe’ve got any other ideas how i can solve this issue.

Best regards
Nikolai

@nathanletwory, do you have ideas? Thanks

Rhino Cycles is probably compiling the kernels. This is in Rhino 8.0, Rhino 8.1 and Rhino 8.2 still happening in the main Rhino process. It means after switching to Raytraced or doing a Rhino Render you’ll have to give it time to do the compilation. On my RTX A6000 and RTX 6000 Ada gen GPUs I have times fluctuate between 5 and 12 minutes.

So, patience.

From Rhino 8.3 (probably becomes SRC in 2 weeks time or so) onwards compilation of kernels will happen outside of the main process in a separate process. While the compile is ongoing RhinoCycles will fallback to CPU rendering until the kernels are ready.

2 Likes

Alright, i guess i’ll stick to rendering with my cpu then for now.
Thanks for your help guys.
Cheers

Hey guys, quick update
the issue somehow resolved itself. After some restarts raytracing now works fine with my GPU selected as render device. Seems like installing the latest nvidia driver did the trick after all.
Thanks again!

That is what I said in two different ways, you have to switch to Raytraced, then wait for it to start actually rendering - kernel compilation is ongoing.

It has now managed to compile the kernels and you have working GPU rendering.

2 Likes