FactorZ Grasshopper Not Working?

I’m trying to extrude these lines downwards in the z-direction. However my file keeps on extruding them horizontally. I’m really not sure what I’m doing wrong even though I’m using the UnitZ factor for my extrusion? Please help.

Just for clarification, I want these lines…

To be extruded downwards instead of horizontally like the top image does.

kagomefile.gh (21.2 KB)

You didn’t internalize your ‘SET SURFACE’ geometry. And I see nothing that resembles the spherical section curves in your image?

I’m very new to this. How should I do that?

Right-click the SET SURFACE param and choose “Internalize data”.

3. Attach minimal versions of all the relevant files

1 Like

I did that but it’s still not working.

After internalizing the surface, post the file here again so we can see it. You probably have a Rhino file open that contains the surface? But you didn’t post it here so we see nothing.

Wait, it’s working now! Thank you!
kagomefile.gh (53.0 KB)

Here is the file regardless though if you wanted to see.

I did nothing! :roll_eyes: :man_facepalming:

An extrusion is not a plane.

I don’t know why but when I opened it in Rhino 6 instead of Rhino 7 it worked.