Can't set surfaces in Grasshopper

Hello Guys,

I have a problem with setting Surfaces in Grasshopper and Rhino. Whenever I have a surface in Grasshopper and right-click “Set one Surface”, it won’t let me select my surfaces in Rhino. I see many people in videos do it and all of my colleagues can do the exact same thing but for some weird reason I can’t. I’m working on my PC right now and It doesnt even work on my laptop. I can’t find any solution online. Hopefully someone can help me.

Thanks in advance.


Maybe good to know: Planar Surfaces on the grid work but I’m talking about simple extruded curves. We are working with Voronoi atm and in the tutorials they draw a curve, extrude it and set the extrusion as surface in GH. This doesn’t work for me.

Post a Rhino file with the geometry that fails for you. Also the Grasshopper file or a reduced version with the relevant components.

Hi Ben,
when you extrude a curve in rhino it becomes an Extrusion (check by typing what with one selected) Extrusions are lightweight representations of extruded geometry that use the 2d input curve and path to draw, rather than a list of connected faces and edges. You need to Explode the extrusion to turn it into a surface. You can reference extrusions as Geometry, Brep or Data. just not as Surface

1 Like

Hi Ben -

Just to explain that part of this issue - you can use the Rhino UseExtrusions command to change the behavior so that regular (poly-) surfaces are created when you extrude curves.

Even if I open a new file, draw a curve, create one surface in GH and try to set this to the extrusion it doesn’t work. I just can’t click on it.

Thank you, the problem is that we use Weaverbird and we need a surface for that. And this doesn’t explain why my colleagues can do it^^When they use an extruded curve they can select it without any issue.

Thanks, I didn’t know that command. I tried it and the extrusion is now a open polysurface but I still can’t select it when I’m “selecting one surface” in GH.

That’s because a Surface component doesn’t accept polysurfaces.

Post your files if you need help.

okay Thank you. When I want to upload them here it says they have 0 MB and it doesn’t work so I made a Transfer-Link: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
This is one extrusion with the surface in GH I can’t set.

A colleague right next to me downloaded it and he can’t do it with my file either but with his own files its working

Something must be wrong with your files. I’m not going to download from WeTransfer. Sorry

I can’t upload files here. I imported some stuff so it’s bigger. It has 70 MB and the site tells me I can’t upload there are 0 bytes

Save a copy of a small part of your file. A single object should be enough.

1 Like

Only export the relevant geometry.

I tried it, doesn’t work. Always says “Sorry, it looks like something has gone wrong, the file you are trying to upload is 0 bytes. Please try again.”

Select a single object and type what in the command Line. Copy that text and paste it here. That will at least tell us what kinds of objects you’re dealing with.


ID: 0453a681-5a00-42d8-a14d-ce6190701587 (85493)
Object name: (not named)
Layer name: BoundaryTower
Render Material:
source = from layer
index = -1

Valid polysurface.
open polysurface with 4 surfaces.
Edge Tally:
10 boundary edges
3 manifold edges
= 13 total edges
Edge Tolerances: all 0.000
Vertex Tolerances: all 0.000
Render mesh: 4 meshes 143 vertices 84 polygons
Created with quality meshing parameters.
Analysis mesh: none present

See how it’s made of 4 surfaces? You need to explode it again and select a single surface. This is why we need to see a file. Screengrabs are great too. If your input curve is smooth you’ll get a single surface when you extrude. However if it has links or corners you’ll get multiple surfaces or a polysurface

I’m more interested to know why you need surfaces as input. This is most likely a hangover from the interests or biases of the person who made the tutorial you’re following. Surely there’s a way to work around this limitation? What’s the goal?

Thank you. Yes, I see. The goal is to make a Voronoi-wall and I use weaverbird as plugin which needs a surface as input.
This is the video I am watching atm: grasshopper voronoi wall facade on any surface |GRasshopper for architecture |[3d beast] - YouTube
From 7:55 you see he makes a curve on the grid, extrudes it and then sets it as surface.
I use this tutorial because I want to give our preexisting wall the voronoi texture. I don’t have much experience in GH, so I don’t know how to work around this.