Extreme lag


I have extremely sluggish reaction times with the new build 5A732. I have never had any performance issues in the previous builds, only since i updated to this latest one. Im running an iMac 2011:

I constantly need to force quit it as it chokes after 5-10 mins. When freshly started it behaves well but more and more modeling and it slows down then eventually no reaction anymore. Sometimes it catches up then works fine and again chokes… Feels like, it runs out of memory or something but all 16Gigs?

The performance issue is on every level. Switching view ports or selecting a new tool there is 3 s-4 sec lag on every task then more and more and it dies eventually.

I disabled history. and purged all data everything…same results

Im wondering if anyone experienced the same problem and could point me to the right direction to fix it.

The machine parameters im having the issues with iMac 2011:Software information

Software versions
Rhinoceros version: 5.0 WIP (5A732)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.9.5 (Build 13F34)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: iMac12,2
Processor: Intel Core i7-2600 CPU @ 3.40GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6970M 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Receiver
Apple Inc.: Bluetooth USB Host Controller
Apple Computer, Inc.: IR Receiver
Apple: Internal Memory Card Reader

Bluetooth devices
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.24.38
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None

I’m also having the same trouble.
At the first time, I also thought that my system might be no longer suit for the latest version of Rhino, but it doesn’t make sense thats because I’m using iMac 2013 late version. Anyway, I did formatting and reinstalling all system and any other application for fixing this problem, but it didn’t fixed.
I mailed to tech@mcneel.com as well, but I got no answer yet.

Please let us know if there is anybody else do this problem.

Could be the OS itself, particularly in 10.10. If you started with some prior version of OSX and have upgraded over time using the migration assistant, any 3rd party extension from previous versions will come along for the ride. As apple continues to deprecate carbon based APIs in favor of cocoa (because that’s what the phones run on exclusively) any places where older Kexts and extensions patch into the OS become potential points of delay. I have a Mac Pro that started with 10.7.5, and under 10.10 it gets dog ass slow, particularly if you have safari open and its accessed and carbon Apis through extensions. The telling factor is to fire up activity monitor, show all processes and sort by CPU used. If window server is gobbling up lots (in my case I often see as high as 90%) you have you culprit.

I spent a solid day rooting out all kinds of 3rd party crap that had been installed over the years and it helped. Still I find myself rebooting a couple times a day just to get something resembling performance back but the second any web browser gets into the mix its just a matter of time before the box drags to a halt. I suspect flash to be a likely culprit, and anything java based as both leak memory like a sieve due to poor programming techniques be every bozo authoring web content.

Thanks for your input LewnWorx.
I had a clean Mavericks (10.9.5) install to start with on a fresh SSD. + 16 Gig Ram so these cant be the source of the problem.
I will see if the new release will fix my problem…

Please keep us posted on what you find in the latest build. It might also be good to have the Activity Monitor application open, watching the memory and CPU. Having some consistent steps to reproduce the issue would be much appreciated.

Thanks Dan!
Yes i had it open and had an eye on it. All was fine for a while but it started to take all memory after some use. And sometimes it would freeze but sometimes not. So its very hard to say if that was the reason or not. It wasn’t very consistent.

I deleted the old build and did a clean install…The new build seems much more stable :slight_smile: much better on RAM too.
1.52 for now…Previously this file would use up like 8 ish…


Same problem here. I was getting the spinning beach ball for extended periods on simple tasks with the previous build.
Updated to build 5A745, cleared a bunch of space on the drive and upgraded from Mavericks to Yosemite. Problem is still bad - works OK for a while after a force quit and restarting Rhino- but then gradually gets worse.

Ahh ok I was too quick to react.
Lag is still there although its much better now but gradually slows down and freezes… still…

I see now that the Mesh settings window has gone south too… cant get it to show…

I just did a test with Safari off and no internet connection. Problem returned after just a few clicks.

This might be a long shot - but looking through my activity monitor I found a MacKeeper helper file which I trashed.
I’ve been working on a 450MB model for about half an hour with no problem so far. I’m calling it quits for the night but will report back tomorrow if the problem returns.

Looks as though that didn’t solve the problem. I worked on the 450MB model for another hour or so without any problem but as soon as I started applying materials in the rendered viewport the problem returned. The problem started when we changed to the new render engine about 2 weeks ago so it appears to be render or materials related.
The problem doesn’t appear to be related to the size of the model - it occurs on small models as well.

We need some help duplicating this. Can you please provide:

  1. a small model
  2. a set of detailed directions for duplicating what you see
  3. your Rhino information from About Rhinoceros . More info…

Marlin, thanks for getting back to me on this.
I’ve spent quite a bit of time trying to isolate the problem.
Firstly- it only relates to applying textures. Secondly, I was wrong about it not being related to model size.
For models of about 300MB it takes two to three minutes for the materials window to open. When I apply the material the spinning ball will spin for hours until I force quit - even with just one or two layers turned on. For a new model with a simple solid there is no problem - materials opens and applies quickly. For a 10MB model it all slows down and sometimes I have to force quit.
I’m starting to think this might be a memory related issue?

Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,3
Processor Name: Intel Core i5
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 12 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM112.0057.B01
SMC Version (system): 1.59f2
Serial Number (system): W81132SFDB5
Hardware UUID: E1CAB3EA-F8FF-5E15-AAD4-0CCFF7D0A673

Could the speed difference be related to the number of materials in your models?

Sure I’m experiencing similar problems, it does appear to be more challenging is the model contains a lot of objects.

Only restarting Rhino seems to resolve the problem, however the recovery is temporary.

Best Graham

Yes my models are complex with quite a few different materials - but they always have been and only since we switched to this new render engine have I had problems.
Would love to hear from anyone rendering models of 200Mb to 300Mb and NOT having problems - then I would know to look deeper into my own system.

I carried out another test to try to isolate the problem of the spinning beachball while applying materials.
I took a model of 360MB with 8 materials and started copying and pasting the surfaces into a new file several at a time. There was no lag because the materials all came in with the surfaces, however at one stage I had to force quit and restart Rhino because the surfaces wouldn’t copy. Once I restarted Rhino they copied again easily.
The strange thing was that when I got up to 325MB I only had one element left to add. That was the lights and they should have brought the file up to 360MB same as the original file. But the file jumped to 615MB!
I successfully rotated the model and rendered it quite a number of times in the perspective viewport.
I quit Rhino and then reopened the file and applied a new material to one of the surfaces expecting Rhino to lock up.
The surface rendered OK with the new material after about two minutes.
Then…the file size dropped back to 325MB!!
No answers in this for me but thought it might be worth reporting.

I guess so, there may be hundreds of components …