Display lag with active clipping plane (mbp retina)


#1

I’ve just got a new mbp with a 2gb graphics card and was hoping Rhino would run like a dream, however disappointed to experience some major lag when orbiting with an active clipping plane.

My previous 2007 mbp didn’t seem to have this issue which is surprising. This leads me to think perhaps I am missing a setting or my discreet graphics card isn’t being used to its full potential. Activity monitor is telling me Rhino is using higher graphics performance but I still baffled about a drop in performance with my new hardware. Is anyone aware of a fix to this?

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-03-17 (506)
OS X version: Version 10.9.2 (Build 13C64)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4850HQ CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Apple: Internal Memory Card Reader
Apple, Inc: Apple Keyboard
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Magic Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.24.9 310.40.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: Medium


(Marlin Prowell) #2

There are several factors here that can effect display speed. Your display has 4 times the number of pixels of your previous display, and you currently have anti-aliasing set to 4x. This means Rhino is drawing 16x the number of pixels it was drawing when on your previous MBP. I’d try setting anti-aliasing to none to see what that does. You already have a retina display so extra anti-aliasing isn’t really necessary.


#3

Thanks for the advice Marlin. To be honest I didn’t really know what anti aliasing did! I’ll turn it off.

I actually had it set to zero when I first experienced the lag so no difference there. I have also reduced the screen resolution to its lowest setting with no change.

It works perfectly until I enable a clipping plane, then it lags. I have tried it since with a simple model and I don’t have an issue so the model must just be too complex. Thought I’d shout up incase it was a common issue and something to that was fixable in future WIPs.


(Marlin Prowell) #4

Your drawing mode can also affect speed. Ghosted mode requires making several passes over the model to produce each frame. Rendered mode requires one pass for each of the lights in the scene to calculate the different shadows.