Extremely Slow Performance


#1

I just obtained Rhino for Mac; one of the first things I did was load a model I created nine years ago in Rhino4 (Windows). The model is relatively intricate, but ran flawlessly on a nine year old computer. On the Mac version rotating the model in wire frame is sluggish, In shaded view is is very smooth. Selecting a command takes a few seconds; I click on a command and it takes about two seconds to come up. When I assigned materials it would take about three to four seconds to drag the material to the appropriate part. It is very annoying. Rendering times are about what I expected, no issues. I assume I need to adjust a few settings on my iMac. Any suggestions?

Model Name: iMac
Model Identifier: iMac14,2
Processor Name: Intel Core i7
Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Boot ROM Version: IM142.0118.B09
NVIDIA GeForce GTX 780M:

Chipset Model: NVIDIA GeForce GTX 780M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 4096 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x119e
Revision ID: 0x00a2
ROM Revision: 3782
Displays:
iMac:
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes


(Marlin Prowell) #2

Using “Reporting Problems with Mac Rhino” as a guide, please post your Rhino info and either post or send us a copy of your model so we can duplicate what you are seeing.


#3

Have uploaded my model via your upload page.

My Rhino for Mac version is: 5.0 (5A855)


(Dan Belcher) #4

Model received. Thank you. I see sluggish performance on my machine as well. Logged in MR-2116.


#5

FWIW, I once had a similar condition the developers helped diagnose that involved essentially invisible micro-lines resulting from complex shapes with numerous trims.

@dan: was the beta routine to find these ever released?

~Dave


(Dan Belcher) #6

Interesting. This was before my time, I think. @pascal, do you know about a Test Command we have used to check for “invisible micro-lines resulting from complex shapes with numerous trims”?


(Brian James) #7

@dan the command mentioned may have been TestRemoveAllNakedMicroLoops


(Dan Belcher) #8

I tried that…didn’t seem to have much of an effect. @BrianJ you might take a look at MR-2116 and see if you can figure out what is going wrong.


#9

I didn’t expect this detailed level of analysis. The modelled parts in the file were imported from SolidWorks (about nine years ago), this may help with you investigation.

I designed the product using Rhino, following approval the engineering department took over detailing the individual parts in SolidWorks. I imported the parts to do some renderings for marketing purposes. That is why I chose this model, I wanted to play with the renderer in Rhino for Mac.

I do not remember this file being slow at all in Rhino4. What I don’t understand is why it is so sluggish in wire frame mode, but very smooth in shaded mode. Rendering the model takes a very reasonable amount of time. My biggest issue is that commands are extremely slow to execute.

In any case all other files I have opened work very well.


(Brian James) #10

I am not seeing the delay in running commands in this file either through clicking on an icon or typing the command name directly. I do see a speed increase in screen rotation when hiding isocurves but it’s not unusable with them on in shaded or wireframe. I also see wireframe as faster here. So not much help yet I know, my initial hunch was that it might be GPU related but I tested it here on a GeForce GT 750M which shouldn’t be that different. One more thing to check @tubrat is if hiding the layer with the lights changes anything for you. It’s not definitely a factor but since there are a lot of them I’d be curious. One last thing, are the display modes set to the defaults in Preferences>Display Modes>little gear icon for the selected mode?


#11

I am sorry; it seems I have been in Ghosted mode. When I switched back to Wireframe all is well. I actually feel pretty stupid right now, I should have realized the difference (I thought maybe wire frame had been enhanced).

In ghosted mode though things are sluggish and commands appear slower to activate.

Again, I am sorry for wasting your time.


#12

That was it. Very handy routine that may help others with odd issues.


#13

I feel the need to add my experience here.

When using my surface pro 3 (obviously not the best graphics card), I’m noticing a pretty huge loss of performance in ghosted mode in particular. It’s night and day when comparing V5 and V6.

Although there are a ton of things that I prefer about V6, when using this machine, I feel I have no choice but not to use V6:/


#14

Hi @Ernest
I believe a forum error. This is Rhino Mac. :relaxed:


#15

Woops!

Thanks.