Really slow response on Rhino


#1

Hi,

Over the last 3 weeks Rhino has become really slow to the point it is hindering my work, rotating , zooming etc is so jittery and there is a lag of about 3 seconds after I click on something before it responds.

I am using version 5.0.2

Any help gratefully recieived


(John Brock) #2

5.0.2 is a very old Mac Rhino version.
I think the current shipping build is 5.3.2.
Please download and install the update (use the replace option), and see if that sorts the problem.


#3

Great I will do that now. Will it transfer over all my files into the new version as it replaces the old version?


(John Brock) #4

That’s automatic. Replacing the Rhino DMG with a newer one will not affect any data files.


#5

what happens is I keep both? It is giving me that as an option. I have so much work in my files I am terrified they might be deleted!! thanks for helping. I am running on a mac not pc


(John Brock) #6

Then when you start the old one, you’ll be pestered that you are running an obsolete version.
The changes are all bug fixes and a few new features.
There is no major version change so there is no reason for concern, but that’s up to you.

If you want, post another message in the Rhino for Mac category asking if any users experiences any issues when they updated from 5.0.2.


#7

Now running up to date version, a little better but still a 2 second lag on response, ie if I put a point on something the point takes 2 seconds to appear. It’s so laboured.


(John Brock) #8

Hmmm…
In Mac Rhino, Rhinoceros > About Rhinoceros > More info > Copy to clipboard.
Paste it into a text file and attach it to a reply.
That should have additional helpful details.

Thanks


#9

Software information

Software versions
Rhinoceros version: 5.3.2 (5D197)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
macOS version: Version 10.10.5 (Build 14F1909)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: iMac14,2
Processor: Intel Core i5-4570 CPU @ 3.20GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 755M 1024 MB
Memory: 1024 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Apple: Apple Magic Mouse
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.4.2 310.41.35f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#10

Thanks for your help btw, :slight_smile:


(John Brock) #12

Does this happen in all files or just this one?
If it’s just the one, is it a big file?


#13

Ahh actually it does just seem to be this particular file.

How do I check the file size?

Another issue is it takes a while to open a file which it didn’t used to do.


(Vanessa Steeg) #14

You might want to update macOS as well. You can verify the file size in Finder.


(John Brock) #15

Can you post the file here?


#16

Hello - I have just updated macOS as well - issues remain.

The file in question is 151.2MB in size - would you expect that to cause these types of issues?

File was too large to upload here so have uploaded into Dropbox - let me know if any issues.

Many thanks


(John Brock) #17

You have a boatload of “bad” curves in your file.
When I run SelBadObjects, Rhino reports:
Command: SelBadObjects
639723 curves added to selection.
https://wiki.mcneel.com/rhino/badobjects

Nothing highlights so I don’t think the bad curves are useful.
I’d just delete them.

Also, your surfaces have way more isocurves than they should for such a simple shapes.


#19

Hi John
Just for curiosity, how do you correctly view this file on Rhino Mac? By opening the file or importing it I get a 25 point view and that’s enough.

Simon


#20

Thanks John,

I will spend the day tidying it up and see if that helps.

many thanks


#21

Unfortunately, Rhino is got an awful lot worse, rather than jittering it’s now jolting on zooming so completely out of control. Constant spinning apple wheel and dulpicating files lasts about 2 mins…I have someone coming out to have a look at it.


#22

for whatever reason, it’s coming in as a .txt file from dropbox-- 13a COMPLETE-slats cut points.3dm.txt

remove the .txt extension then it will open in rhino.