"_ExtendSrf" command weird behaviour in Rhino 8 WIP (Bug)

In the last Rhino 8 Wip Release (4.4.2023) the command “_ExtendSrf” became almost unusable for me, as it extends all the edges of a (trimmed) surface, instead of just extending the selected one.

In Rhino 7, on the very same file, _ExtendSrf works exactly as expected.

Please see attached images.

:: Gian

Image 1: Starting _ExtendSrf command on Rhino 7

Image 2: _ExtendSrf command on Rhino 7 end as expected

Image 3: Starting _ExtendSrf on Rhino 8 WIP

Image 4: _ExtendSrf on Rhino 8 WIP gives weird results (all edges extended)

Anyone has the same issue?
Any clue on what’s happening?

Thanks to anybody willing to help.

:: Gian

PS: Exact Rhino 8 Wip Release is 8.0.23094.11475, 2023-04-04
I also attach sysinfo:
Sysinfo.txt (2.5 KB)

ExtendSrf appears to work properly for me in WIP. Can you provide an .3dm file with an example of a surface for which ExtendSrf does not work as expected in WIP?

Hi David,

I attach here a couple of videos illustrating what happens to me when I try to extend A SINGLE EDGE of a simple (yet cutted) surface. I can’t extend the single edge: the command behave in a totally weird way and extends ALL the edges anyways, whatever edge I specify.

Consider that in Rhino 7 the same surface, from same file (saved in Rh7 format of course) gets extended without any hassle: I lauch the command, specify the edge to exten, and the specified edge (only that one) gets extended.

Edge extension fail 1

Edge extension fail 2


For reference and double checking, here is a video of what should happen if the command would behave normally. Below a video of how the command actually works in Rhino 7 latest release, on the VERY SAME SURFACE, IN THE VERY SAME MODEL/FILE:

Sysinfo is always from my DELL T7600 with updated video drivers.

Sysinfo DELL T7600 - DRIVERS 2023.txt (2.7 KB)

PS: In the previous post I added the third video, showing the “normal” way command executes in Rhino 7.
Could you please check @davidcockey ?

A .3dm file with an example of a surface for which ExtendSrf does not work as expected in WIP would be very helpful to anyone who attempts to help you.

Ops you are right David.
I prepared it but I forgot to send it here: it’s just the surface you see in the videos.

I’ll attach it to te next message in just some minutes…

Here it is @davidcockey

Surface failing ExtendSrf.3dm (65.2 KB)

It looks like the surface is imported from another 3d modelling software, and that It keeps referencing the OG surface (kinda looks a hull to me, and I experienced that same issue many times)
To resolve this : we dup 2 edges, extract a few isocurves, then loft the curves and we have new clean surface that works just fine in Rhino.

As a side note, I notice that the resulting curves from IsoCurves and dupEdge are “wiggly”, I suggest rebuild these curves before Lofting


1 Like

Thank you @farouk.serragedine for your contribute! And welcome on the magical mistery tour of “extendsrf” :slight_smile:

Actually you hit one point: the original file was from a different CAD (solidworks, I reckon).
And your solution for sure helps as a workaround in Rhino 8 WIP.

But in my opinion this behaviour keeps configuring a bug or at least an unwanted regression from Rhino 7 which, concretely, is able to make the command work flawlessly on the same surface and on similiar ones.

Try executing the command on that surface with Rhino 7 and you will see you don’t need to do any preliminary operation: the command just works as expected.

Infact I had to go back to Rhino 7 for working on that file, whom original copy was sent to me by a client and has plenty of surfaces I need to work on, behaving like this one. And of course it doesn’t makes sense to me adding extra work with Rhino 8 where Rhino 7 makes it easy.

So, thank you very much again for your suggestion (it’s now officially in my “book of workarounds for Rhino weird attitudes” : ) but I would prefer this can be solved and Rhino 8 starts to behave like Rhino 7, in this cases.

What do you think @davidcockey ?7

@gian Run UntrimAll on the surface and ExtendSrf should behave normally.

It appears that the surface was imported as a trimmed surface, even though the trimmed edges coincide with the untrimmed edges. This does not usually occur in Rhino. However it should not cause a problem. Would it be okay for me start another thread about this specific problem using your surface as the example? That may make it easier for someone from McNeel to understand the issue and get it fixed.

Hello @davidcockey

Thank you really much: you got the easy way, as “Untrim all” worked immediately and is a simple operation.

Of course this is a better workaround but is, indeed, a workaround: very useful to save the work from longer solutions, but yet a regression in comparison to Rhino 7.

Useless to say, it’s ok for me if you want to start a more specific thread.
I would be happy if you do it.

After you start it I will tag your last answer as the solution.

:: Gian

By the way, I feel stupid not to have thought about “untrim all” for first: but if it takes to fix a regression it was worth the missed solution. Sometimes mistakes are useful.

The problem appears to be with many or all trimmed surfaces in the current version of V8 WIP. I started a new thread about it. ExtendSrf on trimmed surfaces - major bug

1 Like

Thank you @davidcockey !

You’ve been really helpful and I am happy that I could gave my five cents for finding a bug.

The only indesirable effect for you, is that now you are on my book of referrals to tag when I find something “suspicios” (but if you prefer I can remove your name : ).

Have a nice day.

:: Gian

3 posts were split to a new topic: _ExtendSrf in Rhino 8