Exporting linear dimensions to DWG/DXF file

I have one issue which has been plaguing me for years: exporting short linear dimensions from Rhino to .dwg file.

By “short” I mean linear dimensions whose numerical value is quite low, and almost or barely fits in-between the dimension lines.

Here is one example of two dimensions lines: the left one is “short”. The right one is “normal”.
The “Fit text = Inside” is set for this annotation style, which is exactly the behavior I want:

If I export these linear dimensions to a .dwg file, the numerical value of the “short” one is not shown between its dimension lines but right of them. Even though the “Always keep text between ext lines” property is defined inside that DimStyle:

What makes it more confusing is that this behavior is present only for linear dimensions which are exported from Rhino. If I try to make a new linear dimension in Autocad (with that same DIMSTYLE), it correctly shows the numerical value in-between the dimension lines:

Which makes me wonder, if something is wrong with Rhino’s .dwg/dxf export.

Attached are both files.
dim.3dm (36.7 KB)
dim.dwg (18.8 KB)

I used 2007 Natural export scheme. But I also tried with other schemes, with .dxf instead of .dwg - still the same behavior.

I am using Rhino 6, SR35. But the same behavior appeared on Rhino 5.

I would be grateful for any kind of help.

Hello @mary @pascal @wim , @brian
Any help related with this? Thank you.

Hi djordie - does this file look correct, or does it have the same problem?

dimInside.dwg (28.1 KB)


1 Like

Hi @pascal ,
Thank you for the quick intervention.
It has the same problem. The upper screenshot is what I get when I open the dimInside.dwg in both Autocad 2013, 2016 and 2019.
The lower screenshot is if I manually create a new linear dimension, from the same DIMSTYLE - then everything works fine:

Hi djordie -ok, I cannot test this directly but I’ll add a bugtrack item- it’s possible that my more Autocad-savvy coleagues (@mary ) my have a better idea what to do - I just exported from v7 to see if we’d done anything in the meantime to make this better. For the sake of completeness, here is one from V8

dimInside_V8.dwg (28.1 KB)


1 Like

Looking a this now!
Sorry for the delay, @djordje.

Thank you for all the details.
I will dive into it now.

1 Like

Hi @djordje,
Can I get the Rhino 3DM for this?

You can see that these setting are exported and importing correctly.

I made my own, by copying 12.0 and resizing with grips to the 2.8 W rectangle.
You can download it here.

When exported to DWG, they are identical.

So the bug is that both DIMTOFL and DIMTIX were exported as OFF.
I can need to set them to ON so they maintain the parity with Rhino.
I also do not think Rhino is importing these setting back in correctly from DXF.
And AutoCAD does not seems DIMTIX correctly to DXF.

I need to discuss with the developer, hopefully next week.
But it could be likely the following week.

Here is how you can fix in AutoCAD:

Send the 3DM of the 2.8 dimension when you can.
I am curious what overrides are being exported correctly. :slight_smile:
I will get this other issue logged for investigation when the developer is back in the office.

Thanks to reporting this.

Sincerely, ,
Mary Ann Fugier


Thank you for the effort Pascal. Yes, dimInside_V8.dwg shows the same bug.

Thank you for the detailed investigation @mary !

There is no such .3dm. Only .dwg file. You can download it in my initial post (dim.dwg file).
“2.8” I created manually in Autocad, after I opened Rhino exported .dwg.
This “2.8” shows that Rhino correctly exports to .dwg properties of a dimension style, but as you noticed: for some reasons overrides those dimensions style properties by setting “Text inside” to “Off”.

Mary, thank you for showing a workaround (manually setting the the shown properties to “On”). My problem is: I export tens of .dwg/.dxf files during the night with API. Opening each one of them and setting the “Text inside” to “On” manually, can be a tedious job.

1 Like

Hi @mary ,
My apologies for disturbance.
Was there some response from the programmer, regarding this Dim line inside and Text inside properties always being set to Off when dxf/dwg file is exported from Rhino?

Hi @djordje,
Not yet, but there are a few things that are very distracting this next week.
I will let you know in the next couple week or so what can be done and what release you can expect a solution or fix. But typically no time frame will be available to us…

Thanks and sorry for the delay.
Mary Ann Fugier

1 Like

Hi @mary ,
Thank you for informing me. Understood, will wait to see.

Hi @mary , @brian
Can we please, at least register a youtrack for this issue?
Thank you in advance.

Hi @djordje,
Your issue was logged in a private YT with a collection of other DWG export issues.
The way we communicate with Developers is with a YT. So when we say that we are asking the developer for input, there is always a YT associated. It may be private on the system, as in the case because of customer files that were provided for the associated issues in the YT.

Issues that involve UI have been the priority the last few months.
Since there is no UI affected here, the fix can be added at any time in the Rhino WIP development.

I broke out your issue into YT RH-76417.
I think you able to view it in the guest account on YouTrack, but I do not know.

Again, you will be notified here where there is something to test.
In the meantime, you will need to fix these dimension in AutoCAD as we recommended earlier in this thread…

Hope this helps.
Mary Ann Fugier

1 Like

Hi @mary ,
Thank you very much for creating a youtrack issue. I can access it.
I have applied your workaround, but it can be tedious. This week I had to manually open >30 dwg files, select all dimension lines in them and set the Dim line inside and Text inside properties to On. It can be a bit overwhelming.
Hopefully the issue gets resolved in the following period.