Exporting in .eps .ai format

Searched a bit, there seem to be problems… but nothing to help me.

I need to export in either .eps or .ai, the WIP seems to do it but the files are unreadable in any other program (Rhino opens them fine again). I got around this by exporting in DXF format, opening in Inkscape and then exporting in .ai or .eps. I could have also done a vectorised PDF to get around this as well. Is this a known glitch or is it me doing something wrong?

Works fine here. I work between AI & Rhino at least once a week if not more.

This is from this morning …

I usually use export selected, as AI, to get my curves. I also just work in Top view, this has been mentioned to be the best to export lines from.


Thanks Randy, I’ve been doing as you described, tried again this morning, still not working… All the programs I’ve tried opening the .ai with say that the file is not readable or damaged. As I said in my first message I found a workaround, I’m just now more interested to know why my export isn’t working.
NETKA.3dm (54.2 KB)
netka.AI.zip (1.1 KB)

That’s strange your file works fine here.

The only thing I can think of is your version of AI.

Your file opens in AI CC2015.3 for me.

Bonne Chance

Mystery… neither gimp nor inkscape recognise the file. Thanks for checking!

@fuse , what version of AI do you use ?
I can save your file for that version and then send it and you can see if that opens.

Off to work, I can send in a bit if you want to test.

Thanks for the offer Randy, but I managed to make a readable .ai version by importing a dxf into inkscape then exporting in .ai format. I don’t have AI - we do mechanical stuff - but from time to time I have a logo to do. Normally a dxf is sufficient. Thanks again.

1 Like

hi @fuse, the ai file which rhino creates unfortunately demands adobe illustrator only.
this is a “known” at least a lingering bug for a long time now. not even sure if there are efforts
to get this ever resolved… :speak_no_evil: :hear_no_evil: :see_no_evil:

the exporter for the ai file seems to be very old from what i read around here. i also tried
to open that ai without any adobe software which is simply not possible at least not the ai file directly,
the only software i ever got to open it with is cinema 4d but you cant export the files from there,
only rework them as splines for further 3d modeling.

maybe @dan knows anything about it, there was a thread about it once
here you go Reading exported .ai files in vector editors other than Illustrator

Hi @RichardZ, thanks for the additional info, now I know. :grinning:

FWIW, the .ai file that Rhino exports is an .eps file (Encapsulated Post Script). I believe that better support for the modern AI format would greatly improve Rhino.


I agree. Is there any talk of this on the Serengeti category?

Not that I am aware of. This is not on the roadmap for Rhino 6 for Window’s initial release, but is certainly something that could make its way into a service release. I would encourage anyone who values this to make a case on Serengeti.


Thanks Dan

Greetings, I read through this thread and as I have had similar experience’s, felt my input may assist future issues with this import problem.
I have found a work around where one does not have to use a third party software.
To get data from my Rhino to Ai I export the work as a dwg file which I then import directly into Ai, with no problem, size ect. unaffected.
I trust the above may assist someone in the future.
All the best, Rob.

Thanks for the tip @robshaz, the printers - the logo was/is for a t-shirt - asked for the .ai format, I would imagine that they could have used the dxf, I didn’t ask. I was helping out a colleague. I normally work with dxf files for laser cutting, water jet, etc.