Export from rhino to Cinema 4D


we need to export object from rhinoceros to cinema 4D only with quads poly. Rhino after export created triangular polygons, and it crashed in rendering. Do you have some advice, how to export it properly? :slight_smile:

This is how it looks in cinema after export from rhino ( .obj) format.

Thank you R.

Tried Rhino.io plugin?


Get a copy of MoI. Open the Rhino file in MoI, export it as obj, then open in C4D. Much better geometry.

1 Like

Rhino produces NURBS, C4d Polygons.

A NURBSmodel is fully mathematically represented,whereas a Polygon model is not.
That means you can tessellate (“make it Polygonal”) dynamically.
Tessellation based on NURBS is much better, since it better reflects curvature. However its more difficult
to work with it further on, for the same reason.

tessellation can be tweaked in export settings, or better you convert your NURBS model into a polygonal representation within Rhino and export this as obj.

Connection what i solved in the other thread is well rendered, but this part in picture is not. It makes surface errors in the bend.

can you share this (rhino) surface part?

I guess this is what you wished would be in Rhino…
Maybe something for the Sub-D focus of v7.

Conversion of trimmed nurbs to Catmull-Clark subdivision surfaces.pdf (2.5 MB)

you can create a mesh under Nurbs Rules this is true (don’t know the latest versions),
but you cannot work with it further which is fundamental when working with true Nurbs surfaces. You can’t also import nor export surface data.
VRED for instance allows you to import Nurbs, and let you dynamically decide how much each surface is tesselated. This can be modified at any time.

But because this feature isn’t in C4d you will need to use plugins or you do this process in Rhino


with _Mesh you create a Mesh out of surfaces
In this command you can decide the tessellation quality
with _QuadrangulateMesh you try to make as much faces quad as possible

The only weird thing I saw in your data, was that the this inner fillet is not one single surface, instead its a part of greater surface. This might cause wrong shading. So make this fillet single by:
use _split with IsoCurve on and Shrink enabled, join your surfaces again and mesh like above and try to export this mesh to c4d again.

Check also C4d import settings, regarding normals etc… Can’t help further, don’t have access to c4d anymore.

Wouldn’t say this, a surface object in Rhino owns a render mesh for visualisation, but it also contains a mathematical description. So if you modify a surface object in Rhino, you also modify the formula behind. In Cinema4d you create a loft, you can also change that loft, but you cant do more with a loft except lofting. Simply because the loft object returns a mesh only, not a surface object with a mesh. This is a tiny but important difference. If you can import iges, why just not exporting the file in iges then? Don’t know, but iges import seems to be a newer feature… anyways

Actually there are very good render engines out there who can deal with nurbs quite well

Maya (Arnold,MentalRay …) has true Nurbs capabilities whereas following programs do support surface import very well (I only know these, but I’m sure there are more out there):

And not to forget Rhino Render plugins such as
Vray 3 and Brazil