(Exoskeleton) Mesh generation fails at Nodes

Hi everyone,

While generating a mesh from a set of lines the ExoWireframe component fails to generate the correct mesh at the nodes. Instead it messes up the topology and creates the mesh triangles in weird patterns, see the attached image.

Depending on the slider value connected to the “sides” input it may put out a correct mesh, however never at all nodes simultaneously.
Even “smoothing” the wireframe with the “Topologizer”-component does not help.

Has anyone of you ever had a similar problem or could think of a solution?
The GH file is attached, thank you very much for any input!

Kind regards,

PS: I am using the most actual version of the Exoskeleton2 plug-in and Rhino 6.
ExoWireframe_Node_Fail.gh (14.4 KB)

Use Dendro plugin it is based on Openvdb

ExoWireframe_Node_Dendro.gh (26.4 KB)

made two examples for how to solve this with the dendro plugin. option 01 wraps the curves to a given radius. option 02 divides the curves into points and gives different radius values for each point. I made option 02 to show how you can use the plugin to create non-uniform pipes.


If you want control of the size of struts with some smooth nodes you can make bigger struts and then offset negative.

1 Like

You guys are great, thank you very much!

Here you can see what I was going to do with it in the first place:

The smooth transitions to a surface is generated using the method of tensile triangles.
If you are interested I can post the complete GH file or some more pictures once a demonstrator object is printed…

Thanks for posting what you are doing. Yes it will be interesting to see the results. Some year ago I also made a node generator in Nurbs. It worked not perfactly, there is still a component.

Perphas it could be useful.

Dendro offers many possibilities. Here some other way to make sort of smooth transition using curve filet. Sandbox topology is needed.

ExoWireframe_Node_Dendro_LD.gh (47.5 KB)
Some more regular way

ExoWireframe_Node_Dendro_LD2.gh (49.1 KB)


Hi guys,

I encountered another challenge when trying to unite multiple volumes or meshes.

The boolean operations seem to produce strange results, and union does not work, maybe I got something wrong there.

Furthermore, if I try to unite the volumes of the tubes and the arc, the smoothness of the arc is lost and it gets rugged, the mesh output afterwards as well.

Do you have any hints how I could solve these things?
Thank you very much for your support!

Test_Geometry_Tensile_Triangles.gh (140.2 KB)

I looked at your problems. For the union of mesh Rhino didn’t fail. I tested Carverino and it failed like MeshMixer … I am quite sure you can do what you do with Brep but it is another story.

For the union in Dendro it worked but as it is an isosurfacing product defaults have a scale a little less than the voxel size. Nothing magic here but Dendro/OpenVdb is very good.
In magenta Rhino Union, and in blue Dendro

With Dendro when you have invalid mesh put a little value to isosurface.
Test_Geometry_Tensile_Triangles_LD.gh (143.8 KB)

Nota1 : I unweld and weld mesh in order to have some sharp transition
Nota 2 : and if you want to test mesh in GH put a Mesh Edges Component if no E1 an no E3 mesh must be good and closed.


If interested Pufferfish has a closed mesh check.

What’s the best way to grab YANG from the old forum now? I’m having success with SubD in Rhino 7 but would like to compare how it deals with different angles in comparison!