Evolute Tools freezes up Rhino in cold start



Hey there!

from time to time i have problems opening a file, i worked with Evolute in before. Rhino 5 freezes while opening after the Evolute Logo appears and asks for reloading the optimization settings. Whatever i click - yes or no. It shows up my model and freezes then.

It happens with easy models, and with coplex ones.

I run on Windows 7.

(Alexander Schiftner) #2

Hi, many thanks for your feedback. Please help us solve this problem by answering the following questions:

  • Could you please send one of the files you are having troubles with
    to support@evolute.at, or post it here?
  • Does this problem happen
    every time you open such a file (i.e. does the file become broken),
    or sometimes it happens and sometimes it doesn’t?


It happened to me with different files, and doesnt work anymore. Neither due opening in explorer with doubleclick, nor in opened rhino with preloaded plugin.

Subdivision.3dm (735.1 KB)

(Alexander Schiftner) #4

Hi Simon, I could load the file you sent without troubles. Did I understand correctly that this file does not load at all on your workstation?


After i restarted Windows 7, i was able to open it again! I have 8 GB RAM
and an SSD. Could it happen because of Memory reservations? Because usually
i don’t restart for days…


After a windows and Rhino restart it said as well that the Evolute Tools
Plugin failed to load last time, and if i want to use it still.

(Alexander Schiftner) #7

Hi Simon, many thanks for your feedback. I guess something was using up your memory. Next time it happens please start task manager and have a look for Rhino processes that are running in the background. This issue has been reported to us previously and will be fixed in the next release.


I’m having this problem regularly as well with Windows 10 and Rhino 5 64bit.

I opened the task manager when it was doing this and saw two instances of rhino running, one working and one not responding, I closed the working one, then the not responding one opened OK.

It happens for me after every first use, so If I boot my computer, I can open and use Evolute based files no problem and use the tools without issue, if I close Rhino and open it later with no restart of the PC, I get this issue.

I also noticed that there are few instances of the toolbar/tab registered for Evolute tools, I think this is because I un-installed and reinstalled because of some other problems, - How does one go about unregistering toolbar tabs in Rhino?

Thanks, Andrew

(Alexander Schiftner) #9

Hi Andrew,

regarding toolbars: If you have several instances open, please use Rhino’s _Toolbar command to close the ones you don’t need.

regarding the problem with Rhino hanging: Please do the following experiment and tell us the result: Start the task manager, then close Rhino, and check the task manager whether the Rhino process shuts down or hangs forever. Shutting down may take a few seconds due to EvoluteTools’ license checking.


Hi snabela,

Thanks for the reply.

RE the toolbar, I don’t have them displaying, but there are duplicate versions ‘registered’ and I don’t know how to un-register them

RE the hanging - I tried this, but typically it is not hanging now! -

what I did notice when this did hang earlier, was that there were two Rhino.exe processes running . I will check again next time it happens and report on the problem.

(Alexander Schiftner) #11

RE the toolbar: I think you dragged & dropped the EvoluteTools toolbar to your default toolbar, which is fine but creates a copy. You can just right click and delete it.

RE the hanging: It’s good to know that it doesn’t hang every time. It seems that sometimes when closing Rhino and immediately starting it again, EvoluteTools license checking runs into a deadlock. We will investigate this.


Re Toolbar - Oh, that simple ! Yes, that did it thanks.

RE hang - That makes sense, although I think it has happened before after opening some time later, but at least I know how to overcome this by ending the duplicate instance in task manager for now though.



Got the same problem here - Rhino locks up when opening a file with EvoluteTools meshes, at "Creating reference mesh…"
CPU load is 50% (quadcore).
I happens every time I open the file.

However, using Import instead of Open can load the scene.
Named Views will be lost, though.

I the attempt to keep the Named Views, I did this:

  • ‘unplug’ EvoluteTools by renaming the installation folder
  • start Rhino open scene (works now)
  • delete everything except the Named Views
  • save & close
  • plug in Evolute again (folder rename)
  • Open the saved empty file - ET asks “Do you want to load saved optimization settings” - yes.
  • Import the scene - Rhino hangs.
    There is something in the settings that causes the hang, as it looks.

Thanks for looking into this!
Best regards

I could salvage the corrupt file by Importing it, then using “Import from 3dm file” in the Named Views panel. Saving/loading works again.

(Alexander Schiftner) #14

Hi @Eugen, please let me know which version of EvoluteTools you are using. EvoluteTools prints its version number to the command history window at loading. Thanks!
Would you be able to send the Rhino file to me, which causes EvoluteTools to hang?


Thanks for getting back on Sunday!

Loading EvoluteTools for Rhino - Pro (170822_EVOLUTETOOLS_PRO_2_5)…


Mail to support@evolute.at is underways. Thanks!