Error with WallProfile - bug?

Hello,

there is some strange issue with the WallProfile-Component. I use a list of Curves as input to the Profile Connector, and for some reason some of the curves don’t work; they even block the execution of the following curves. The Input Curves are all generated the same way in grasshopper, they are planar, closed and have correct directions. I also tried to rebuild the curves from their Control Points…

Can anybody take a look over this? Thank You!

test_WallPrfl.gh (30.8 KB)

Still looking these, there are some with single windows that just aren’t cooperating.


Re_test_WallPrfl.gh (40.0 KB)

So how can this be solved? Should I provide more information or does it help if I do futher testing?
As said, I didn’t find any workaround yet to get this walls working.

It would be great if that could get fixed somehow; at least the component shouldn’t stop at the first error.

I use Revit 2022 and the latest daily release RiR-Version.
Thank You!

Hi 3ACHS, That component has a couple issues; the error handling and the curve processing. Hopefully we will have some fixes in an upcoming daily; the error handling should be fairly straight forward, the curve processing is trickier due to GH does return curves from surfaces in a consistent direction, something that is scheduled for GH2.

Looking at the actual work there are a few other ways to do this. Is the intent for these to be modular prefab units? In that case using a curtain wall with walls as panels is an option.

Another is to use openings or windows in a full height wall.

I’ll make quick examples of both in case that’s an option.

Hello Japhy,

there will be also gable shapes, so the full-height-wall-with-opening-approach will not cover all cases.
I will test the curtain-wall but I am not sure whether my client can use them.

The Curves should already have the correct directions; they are not combined edges from some surfaces but I construct them from scratch.
Just an idea: maybe it’s a solution to provide surfaces instead of Curves?

Thanks for looking!