Error with the revolution component on Grasshopper in Rhino 6 WIP for Mac


(O Ismail) #1

Im trying to use the revolution component to revolve a structure around an axis and despite ensuring that the inputs are correct, the revolution component is giving an error stating: The object contains one error and under that is says Solution Exception: ON_RevSurface_Create. My course instructor didn’t even know what to do.

Any help would be much appreciated


Rhino 6 for Mac WIP build 6.13.18352.12046
(Michael Pryor) #2

Files? Screenshots?


(O Ismail) #4

I even tried using the revolution component in different scripts and it gives the same error


(O Ismail) #5


(Chris Hanley) #6

I think it might be related to this? I don’t have the mac version, but maybe it’s the same/similar issue?
Based on the error you show, I don’t think it’s anything that you can do at the moment, aside from trying an older, (or newer?) version…or using an approach that doesn’t use a revolve.


(O Ismail) #7

@dan
Hello,

As requested, I have attached the grasshopper definiton and a screenshot of it below to show you how it appears on my computer.

System Info:
Rhino 6 SR12 2018-11-13 (Public Build, 6.12.18317.12076, Git hash:master @ 069b1aed33ba5c9e6b04dd9e509ff8509a57719d)
Licence type: Beta, build 2018-11-13
License details: Cloud Zoo. In use by: Omar Ismail ()
Expires on: 2018-12-28

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G65) (Physical RAM: 8Gb)
Machine name: Omar’s MacBook Pro
Language: en-CA (MacOS default)

Intel® Iris™ Plus Graphics 640 (OpenGL ver:4.1 INTEL-10.36.19)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Driver Date: (null)
Driver Version: (null)
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Displays: Color LCD (256dpi 2x)
Screen size: 1440 x 900

USB devices
None

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
None

Rhino plugins
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.12.18317.12076
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.12.18317.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.12.18317.12076
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.12.18317.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.12.18317.12076
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.12.18317.1002
/Applications/RhinoWIP.app/Contents/PlugIns/Alerter.rhp “Alerter” 6.12.18317.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.12.18317.12076
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.12.18317.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 5.1.2015.132
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.12.18317.1002

Revsurface Bug.gh (16.8 KB)


(O Ismail) #8

@dan
Is there anything I can do about this in the meantime or do I need to wait for an update to fix the bug?


(Dan Belcher) #9

I don’t know. I’m still investigating.


(Dan Belcher) #10

Hi @o.ismail-

Sorry this took so long to test and verify. This is a bug RH-49621. Thank you for reporting it.

To be more precise, this is a bug in the RhinoWIP for Rhino 6 for Mac. That said, the definition you kindly uploaded does indeed work in Rhino 5 for Mac (tested in 5.5.2). Since you are using the RhinoWIP, you have access to Rhino 5 for Mac so you can fall-back to that until this bug is fixed.

Thanks again for reporting this and providing a definition!


(O Ismail) #11

Thanks a lot for looking into it, I ended up achieving my desired goal using different components.

Thanks again for your help


(Dan Belcher) #12

FYI, this should be fixed in the latest RhinoWIP. RevSrf should rev…surf. Please give it a spin :drum: