Crashing: Ghpython component crashes Rhino when autocomplete kicks in on type hint Surface?

I am running into an issue that is crashing Rhino.
Steps are: (PLEASE NOTE: If you replicate these steps, you may experience a HARD crash of rhino/GH. )
1 - open new/blank Rhino document and new/blank grasshopper definition
2 - add sphere component (which yields an untrimmed surface) to grasshopper definition
3 - add python component, set input x type hint to surface
4- in python component editor, as soon as I “type x.”, (where autocomplete would kick in), it crashes rhino.

The issue seems to be specific to setting the type hint as surface. I tried a few other type hints with different geometry types and it seems okay. Below is my system information.

Rhino 6 SR7 2018-7-12 (Rhino 6, 6.7.18193.18031, Git hash:master @ 4d7c3923814d6480de22b1d466054078f406725d)
Licence type: Commercial, build 2018-07-12
License details: Cloud Zoo. In use by: chanley ()

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: LP-6014FC2

Quadro M2000M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 389.08)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-27-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18193.18031
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18193.18031
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\chanley\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.7.18193.18031
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18193.18031
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.7.18193.18031
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18193.18031
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I reproduced, and sent in a crash report for good measure. It didn’t right away crash for me though. The very first autocomplete worked fine, but then I did print(x. and then the autocomplete hung, then crashed.

Thanks! I tried a few times to make sure I wasn’t doing something wrong. I sent in one of the crash reports with a description as well.

Thanks @chanley

I looked into this and determined that it is the getter of RevSurface.Curve that is crashing Rhino; this function.

I added a YouTrack report: RH-47447. A dev will look into this.

Thanks for the report!

RH-47447 is fixed in the latest Service Release Candidate