Revsurf component not baking

grasshopper

#1

This has probably been spotted, but I can’ bake a revolution surface (rev surf component) to Rhino.


#2

An important detail I missed: the brep the component generates is invalid. It is the revolution of a catenary curve.


(David Rutten) #3

Grasshopper will always refuse to bake invalid geometry, so the question is why is this shape invalid and does it happen on Windows as well? Can you post the gh file?


#4

I haven’t tried it on windows yet but here it is the file.

Untitled.gh (17.5 KB)


#5

I’ve already tried it in windows an it happens the same. In the file I sent the Catenary component isn’t connected to the input § of the RevSrf component. Baking the curve to Rhino and revolving it works fine.


(David Rutten) #6

One of the problems is that you’ve got a full profile, revolving through 360 degrees (2pi radians). This means you’d end up with a surface that is ‘doubled up’. Reducing the revolution angle to only 180 doesn’t fix the problem though, it results in a different invalid surface (these are bugs that need looking into on our end, but I can sort of see how you couldn’t end up with a valid revolution this way).

If you cut your catenary in half though, it will result in a valid revolution (see attached). Do note that the catenary component outputs polylines, not smooth nurbs curves. You may want to fit a nurbs curve through these polylines for your purposes first.

invalidbrep.gh (13.2 KB)


(David Rutten) #7

Here’s one way to convert your catenary polyline into a smooth nurbs curve. But of course doing so will mean the exact length of the nurbs curve isn’t what you asked for, it’ll be slightly too short.

smooth_catenary.gh (15.2 KB)


#8

Thank you for your valuable input. Indeed having a clean surface was one of the problems I was also trying to sort out.


(Renato Cosenza) #9

I have the same problem

https://discourse.mcneel.com/t/grasshopper-cap-dish-does-not-bake/62912