Error saving RUI - again


#1

The SR8 is downloaded and installed:

V5/64: (5.8.40225.8390, 25.02.2014)
V5/32: (5.8.40225.8390, 25.02.2014)

When Rhino ends, then this comes up in BOTH, V5/64 and V5/32:

Again the question how to go back to SR7.
We need an answer soon.

Thanks,
-C-H-A-R-L-E-S-


Error Message On Exit
(Steve Baer) #2

@JohnM I thought you fixed this. Could you please take a look?

@brian, do you have any suggestions for rolling back to SR7?


(John Morse) #3

There is no need to go back to SR7, there is an easy fix for now. To fix the problem start Rhino, run the Toolbar command, right click on the “PanelingTools” file, choose “Save As” and save the file in your “%APPDATA%\McNeel\Rhinoceros\5.0\UI” folder. This is the same folder your default.rui file is currently in and it is a writable location. I will investigate what might have caused this to happen.


(Brian Gillespie) #4

Going back to SR7 is pretty straightforward, but a little time consuming:

  1. Open Programs and Features
  2. Uninstall everything related to Rhino 5
  3. Download and install SR7 from http://www.rhino3d.com/download/rhino/5.0/latest

(Wim Dekeyser) #5

I’m feeling left out…
How do you get a hold of the 2014-02-25 version?
From Rhino, Updates and Statistics says I have the latest version (2014-01-28 which, as mentioned in another thread, I know not to be true). Going to download.mcneel.com and looking for the latest release still only mentions 2014-2-14. [SR7 is 2013-12-13]. What’s going on?


(Pascal Golay) #6

Hi Wim- you need to have ‘Update frequency’ in Options > Updates and statistics’ set to “Service release candidate”. If that is the setting and you are not seeing updates … and Check Now does not give anything useful, let me know, something’s gone wrong.

-Pascal


(Wim Dekeyser) #7

Pascal,
Yup, set to candidates and Check Now doesn’t give anything useful. I’ll install the 2014-02-14 that I downloaded manually a while back and see what that gives.
cheers,
wim


#8

Definitely broken here, was already with the last build… still broken in this one. --Mitch


(Wim Dekeyser) #9

Yea, a manual install of 2014-02-14 doesn’t help…


(Pascal Golay) #10

@brian, any ideas why updating seems not to be working?

-Pascal


(Brian Gillespie) #11

Manual installs of older builds do exactly nothing - you’ll need to uninstall first.

To manually download the latest RC, visit http://www.rhino3d.com/download/rhino/5.0/latest/rc


(John Morse) #12

I was able to reproduce the Paneling Tools RUI file writing error and get it fixed. The problem should be resolved in Rhino SR9.


(Wim Dekeyser) #13

@brian, I guess you are missing the point. I was not manually installing an older RC over a newer RC. My Rhino said it was up-to-date to the latest RC, which I knew was not correct. I had downloaded a newer RC a while ago but hadn’t installed that yet. I was hoping that installing this one would now trigger automatic download of the latest version - which, from everything that is being said in several threads here, sounds like should be the SR8 (final). But it doesn’t.

But now you’ve got me totally confused…
http://www.rhino3d.com/download/rhino/5.0/latest - SR7 - 2013-12-13
http://www.rhino3d.com/download/Rhino/5.0/sr - not sure - 2014-02-14 (my current)
http://www.rhino3d.com/download/rhino/5.0/latest/rc - not so sure either - 2014-02-24
But Charles and all of his customers are running the 2014-02-25 version…


#14

Now the confusion seems to be complete…

Is there a SR8 or a SR8RC?
Brian said SR7 is the latest…

I got the latest release with this setting:

-C-H-A-R-L-E-S-


#15

This means it is not possible to uninstall a SR?
In V4 it was…

-C-H-A-R-L-E-S-


#16

Yes, that works ok now!

Thanks,
-C-H-A-R-L-E-S-


#17

No, it wasn’t. It always looked like it was, but it never worked. If you wanted to roll back to an earlier version it was necessary to uninstall Rhino, reinstall from the disc and then reinstall the service pack.

–Mitch


#18

I have the same problem since the last 2 updates.
Version 5 SR8 32-bit
(5.8.40224.15545, 24-2-2014)

Thanks,
Gerard


(Brian Gillespie) #19

It may appear that uninstalling an SR for Rhino 4 worked, but in fact it did only one thing: remove the Add/remove programs entry for the SR. In fact V4 was more complex because you needed to remove ALL installations, including SRs, and then reinstall from scratch to get to a specific service pack.


(Brian Gillespie) #20

SR8 has not yet been released - we’re still at RC3, finishing a couple little bugs (including the saving RUI file bug in this thread). I’m not sure how you managed to get SR8 with your setting set to Service Release. That’s pretty disconcerting.

Fortunately we logged everything the update system did, so we should be able to figure it out. Can you please do the following:

  1. From the Start menu in Windows, type Event Viewer, then press Enter
  2. In the Event Viewer dialog, browse to “Applications and Services”->“McNeel”
  3. Right-click “McNeel” then click “Save all events as…”
  4. Select “CSV (Comma Separated Values) (*.csv)” from the Save as type drop-down, then save the file to your desktop.
  5. E-mail the resulting CSV file directly to me (brian at mcneel dot com)

I hope I’ll be able to figure out what happened to get you that build.