Error in exporting Rhino Step AP203 format?

My client likes to export a Rhino Step file to this companies service called Sophia:

This webpage mentions that they support Step AP203 format which Rhino also supports.

However, the TailorSteel company says that the export is not correct and they have more Rhino customers with that problem. A workaround is to export via SolidWorks as that works fine. However my client doesn’t have Solid Works.

To my idea two options are possible, Or Sophia doesn’t read well this specific Step schedule, or Rhino doesn’t export well.

What can we do to solve this problem?

This is my client’s test file.
Plate cutting test Step.3dm (93.3 KB)

Here’s some info on the problems:
Here is the link to the Sophie software provided by TailorSteel. This software recognizes the individual plate and tube parts, and develops the tube cut profiles from 3D to 2,5D

Attached is a screen shot of the how the Rhino step file is received by the Sophie software.
Apparently the software does not recognize closed solids in the Rhino step file.

That last screenshot is from SolidWorks. Testing the Rhino export from your posted example produces a solid for both the AP203 and AP214 versions of STEP in SolidWorks. Therefore the problem appears to be with your tube file in the screenshot.

Hi Gerard - can you post or send me an example of Rhino step output that is not working and the SW output that is?



Hello, this is Ventura Welding, the company having the problem with the Sophie program. In a a nutshell the Sophie system fails to interpret the closed polysurfaces as solid parts.
First attachment is the Rhino step file that I’ve sent to the Sophie program, and then the Solid Works step versions that were “clean up” by Tailor Steel which can be exported into the system without a problem.
What could be the difference?
I’ve also tried exporting the parts individually without success.

Here is a simple plate test, that also could not be imported successfully into the Sophie system.Plate cut test Rhino step AP203.stp (53.7 KB)

Looks OK here - I get

Valid polysurface.
Closed solid polysurface with 11 surfaces.
Edge Tally:
1 seam edges
26 manifold edges
= 27 total edges
Edge Tolerances: all 0
Vertex Tolerances: all 0

However, the hole in the middle is one closed cylinder surface (note the “seam edge” listed above) - some programs do not like closed surfaces, they like 2 halves… Does the following work better?

Plate cut test Rhino step AP203-msh.stp (32.2 KB)

You can set this automatically in the STEP export options…

Maybe this will help… --Mitch

Thanks Mitch, just tried it, along with some other option variations, and no luck.

Hmm, OK, I have no idea what could be going wrong then… I don’t have any other software to test STEP imports with, but the part you posted looks so simple I can’t find anything that might be faulty about it…

@venturawelding Hi Andrew - thanks - another shot in the dark but can you please try this file?

PlateTest_PG.stp (31.9 KB)

Meantime, I’ll see if the developer can help sort out what the difference might be.

@venturawelding - it would also be helpful to have the Rhino model (3dm file) that has all of the objects that are in the largest step file you sent us.



Hello Pascal,
The file that you sent me worked! Now what was the difference??
Here are the original 3dm files.Plate cut test - Rhino 3dm.3dm (96.5 KB)
Pipe test cut - Rhino 3dm.3dm (316.3 KB)

Hi all,
same problem here, I made a simple clean extrusion in Rhino, used the default settings for export, AP214 automotive design.
It seems this topic ends with no final answers so any help would be highly appreciated.


I have investigated step file: Pipe cut profile test Rhino step AP203.stp
I found 2 types of error why Sophia isn’t loading the step file correct:

  1. some solids are grouped together as one solid:

  2. All faces are BSplineSurfaces. For Sophia to correctly recognize the tubes the surfaces must be geometricaly defined with Planer faces and Cylindrical surfaces: