STEP export

Problem:
Exporting to *.STEP from Rhino results in a file that is not readable for many manufacturers.

Situation:
My current project involves bending sheetmetal. Manufacturers usually want a *.SLDPRT or *.STEP file. When the process is completely automated and you just upload a file, then it is *.STEP only - at least in my region. Rhino is generally a bad option when it comes to designing sheet metal parts. That’s why I also use Fusion360. In the current project though, the parts don’t have very tight tolerances, bending shortening (k-factor) can be neglected and they are rather simple overall. That’s why I wanted to use rhino and grasshopper for the current project - it’s by far my first choice.
This turned out to be problematic anyway. I have to submit STEP files, no other option. My grasshopper definition calculates the final part and it can even export to STEP, sounds nice, except there is a problem. STEP output from Rhino/Grasshopper isn’t usable because many manufacturers can’t read it. Where I upload the file, I get an error message.
I had this before in another project and different manufacturer where the process isn’t automated. Whatever STEP export option I chose, they always told me, “sorry we can’t read your file”. I had to use Solidworks back then. Later I got to know Fusion360 and used it instead of Solidworks.
I thought this time I would be able to make STEP work but it is still not possible, whatever I try. Now I have to export the flat DXF from grasshopper, import it into Fusion360 and there use the sheetmetal tools to recreate the bends. STEP export there works as expected - of course.

I know that STEP export actually does work with some manufacturers. There is one where the process is also automated and it accepts the STEP exported by rhino. Though this manufacturer is in some regards too limited for me which is why it is not an option for me.

This bug is known since a long time and many have complained about it but nothing has happened. I hope it will.

Solution:
Fix it

Hello - there is almost no hope unless you provide files - we’d need the Rhino file and the exported step file at least - as simple as possible an example would be best. You can post here or send to tech@mcneel.com along with a link back to this thread in your comments.

-Pascal

it can be reproduced with any Rhino to IGES export. I made a quick example, attached to this post. there is a simple u-profile part in the 3dm file. when you export it to step, no matter what option or checkbox, it won’t be accepted by the manufacturer. a step export from rhino is attached here as well. the 3dm file also has the unrolled curves, layer “DXF-EXPORT”. I exported the curves as DXF and then imported them into Fusion360 as sketch. based on that sketch, I made the bends there and then exported it. this fusion360 step export is also atteched here.

the fusion STEP works fine. the rhino step does not. the company I uploade it to is TailorSteel. you use their software to do it, registration as comany required. the error message for the rhino-step says “No planes or tubes found”.

I tried to find out what the problem might be. when I re-import the step that was created by fusion360 back into rhino, then you can see that it is quite different. the surfaces are untrimmed. no idea if that’s the problem. opening a step with a text editor was surprising to me. step files are actually quite readable to humans, similar to svg files. comparing the rhino-step and fusion360-step you can immediately see that it looks different.

maybe this additinal info helps to find the problem quicker. I hope it is something simple to fix.

here are the three files:
rhino-test.3dm (170.8 KB)
STEP-export F360 example v0.step (83.9 KB)
STEP-export RH6 01.stp (144.5 KB)

Known for their non-acceptance of Rhino-sourced STEP files. There are a couple of threads about this floating around here.

…and does any of those threads provide a solution?
NO!

and it’s not just that company. I’ve worked with others before and they couldn’t read the rhino-exports as well.

So whose fault is it? It it a problem with Tailor Steel or McNeel or both? Why don’t you ask Tailor Steel why Rhino-generated STEP files don’t work - when they do elsewhere for the most part?

Yeah, Chuck tried to get some action from them (TS) and seems not to have been able to-

-Pascal

as I mentioned twice, it is not just TailorSteel! Exactly two other companies I know can’t read it either. That makes it three.

so that’s it now or what?! you are not doing anything now, really?!
you just blame others and avoide making your the software you sell actually usable in a production environment - great customer support!
I really hope this is a joke!

I provided you with details and files. if that one company does not answer then probably because they can’t help. check out what machines they use, that would be TRUMPF for example, other too. what about you contact them, because they are the ones who made the software that runs the machines.

I don’t think your crabby remarks do very much to further the search for a solution to the problem. It seems to me that Chuck has made some efforts to get the info he needs but met some obstacles. Hopefully your sample files of the same part exported from Rhino (non-working) and fusion360 (working) will give him something to work with. Perhaps now that you have identified the manufacturer of the troublesome hardware/software he will have another avenue from which to seek information. How about identifying the other two fabricators for him so he can see if one or both are more accessible and cooperative?

4 Likes

Well, reading the completely unneccessary remarks by @Helvetosaur it looks like there just isn’t any motivation to solve the problem. But I don’t know if he works for McNeel, it’s not in his username. I hope not. With such an answer, I think it is understandable that I responded with frustration.
Still, you are right, that does not help to solve the problem as well. I just sent a message to @pascal, containing the other two companies. Though I doublt they are of any help in this matter. I suspect the problem might be at the interface to the machines, that’s why I brought up Trumpf. If it has something to do with their Software, then I’m sure it is solvable, since they should have a big interest, that their machines work with as many CAD software as possible.

Hello - please see the developer’s comments here:

If Tailor or the two other companies you mentioned respond to our queries, there is an excellent chance we can tune up Step export to suit. It is also perfectly possible for them to tune up their step import, since, after all, many different programs are perfectly happy with Rhino’s step files - I assume you’ve also been putting some squeeze in that direction as well - with a bit of pressure, perhaps they will talk to us…

-Pascal

Indeed I did contact TS regarding this earier today.
I’m full of hope!