Enter-key not recognised (in Rhino 5 for Windows)


In Rhino 5 for Windows SR7: Occasionally the enter-key, space bar and right mouse button don’t work to end/exit a command (e.g. stop drawing a Polyline). What is going on? Help!

Best M

Hi Manuel- do you have a repeatable example? Can you try a different keyboard, maybe?



I also have this problem from time to time when drawing a Polyline.
I will try to find a repeatable example.


We hear about this from time to time if the user has been scripting (RhinoScript, python, Grasshopper scripts). Unfortunately we haven’t figured out a way to track down the actual problem so we can repeat it on a developer’s computer.

It didn’t happen for a while now. Indeed it occurred when I used rhinoscript before. I remember that while trying to escape from a command, such as polyline, the message (“An installation of Dimension Catalyst software cannot be found.”) showed up in the command window. This happened several times without using the actual Catalyst command. Mysterious!

Did anyone find a solution to this one? It seems to happen quite frequently for me at the moment while running grasshopper.

Maybe a repeatable example

It occours following a grasshopper bake but not every time. I will happen on a fairly regular basis so after about half an hous it will occour. The solution is to restart Rhino.

I will keep a note of what I did to cause it.

Now it happened again out of the blue (working on a python script)… once it occurs pressing

the ESC button results in:
Command: _Catalyst
An installation of Dimension Catalyst software cannot be found.

the Enter button results in:
Command: _Insight
An installation of Stratasys Insight software cannot be found.


I’ve got a single designer in our team that is getting this but only after she runs a specific Grasshopper script and only on her computer. And it’s other keys that aren’t recognized such as Del or Esc. Mouse interactions work, Typed commands work, but not certain keys that do commands themselves. When first executing Rhino, it’s fine. When first launching Grasshopper, everything is fine. As soon as she opens the grasshopper script (a panel face generator), the keys quit responding. Sometimes, no errors will show, sometimes I will get the “An installation of Stratasys Insight software cannot be found.” error.

We’ve tried uninstalling Grasshopper and even the other plugins we use (Lunchbox and Paneling Tools), even a complete uninstall and reinstall of Rhino and the same issue occurs the moment she opens the Panel Face Generator script.

My first thought as repeatable as this was is that the problem is with the script, but her computer is the only one with the issue and if other people sign in to her computer, the problem persists so it’s not her profile.

It may occur frequently when having autocad opened in the same time. Rhino, grasshopper, autocad it,s a deadly combination which ends up with “An installation of Stratasys Insight software cannot be found”, enter and esc not working.

It happens here also and I dont have autoCAD installed.

When grasshopper opened. I can still type a command but cant enter it to make the command running. Esc is also out of the question.

I have the issue with some regularity, but not repeatably enough to conclude anything yet. I have GH but not AutoCAD.

I and a number of my colleagues are also suffering from this same problem with some regularity when using Grasshopper. I get the same messages about Dimension Catalyst and Stratasys Insight, so tried disabling those plugins, however this did not solve the problem (although it has stopped those error messages appearing). I thought at first this might be a problem with Grasshopper stealing keyboard focus, however I can still type commands in Rhino, I just can’t execute or cancel them using the keyboard. Completing commands by selecting things with the left mouse button works, but commands which require confirmation are impossible to complete either with Return or the RMB. Running commands cannot be cancelled using the Escape key, however escaping using the ‘!’ character works OK.

Typing in commands and pressing return will result in the ‘_Catalyst’ command being entered instead (even when the plugin is disabled). However commands selected by left-click from the drop-down suggestion menu will be entered successfully, as will commands triggered by left- or right-clicking on a toolbar button. Pressing Escape at any point will result in the “_Insight” command being run (again, even when disabled). Neither “_Catalyst” or “_Insight” appear in my Aliases list.

The only way I’ve found to restore normal behaviour is to close and re-open Rhino. The behaviour seems to be semi-random but is definitely more common with some files than others. If I can create a repeatable example I will send it.


I have completely reinstalled my PC and added Rhino for Windows.
After I save a script, enter and esc doesn’t work anymore in Rhino.
This can be reproduced every time, so no random problem.

At the people from Rhino: How can this be solved?

I am having this escape key issue as well. Can’t cancel any commands or stop displaying points by hitting escape. shift-! does work though.
I can’t isolate a reason (file, command, script, etc.) It used to be random, and fixable with a rhino restart, but now after upgrade to:
Version 5 SR10 64-bit
(5.10.41201.11145, 12/1/2014)
a rhino restart is not fixing it.
Anyone have any new info about this? I don’t have GH running right now either.

UPDATE: I found this info about photoshop causing key mapping issues when running in the background.

Further down the page people are talking about some other things that might be the cause (intel/nvidia graphics yaddayadda, etc)
Maybe something that helps some of the above posters…
For me, closing my cs3 solves it. Also, shift-esc is recognized by rhino for those times I need photoshop open at the same time.

Yep, same issue for me… No escape key in Rhino, and getting message “An installation of Stratasys Insight software cannot be found.”

Using grasshopper… but haven’t baked anything.

I have also been running Revit at the same time?

Simply restarting Rhino has fixed it for me this time :smile:

Yes, I keep getting the same error and I am stuck. I do not have “Dimension Catalyst” installed.

What to do?

Same here, baked a component, and now I get all these messages.

Screenshots, while pressing Esc, Space and right click.