Esc + Enter Key stop working

Does anyone have the same bug as me? Esc + Enter +Delete Key show no reaction after using the Python editor. Even when using Rhino in save mode. I tried this on other computers too. It does not happen on all of them.

I’ve never seen this. Does it only happen with a specific script?

On any script. I can get the error like this:

• start Rhino to an empty doc.

• start python editor.

• write any script eg: print “Hello World”

• Run script

– All key still working fine–

• save script on desktop (Win 7).

– now the ‘Esc’ , “Enter” and ‘Del’ keys stopped working —

So far I only had this problems on PCs that have Visual Studio installed. But it might also be related to other software. So thats why I wonder if someone else has the same bug.

The same happens when using the VBscript editor.

Strange, those are completely different editors with a totally different underlying code base. I haven’t heard of this happening before and we all definitely have copies of Visual Studio 2010 and 2012 installed on our computers here at the office.

yes it is really strange, I had that bug already at Zaha’s in London and now at Waagner-Biro too. Even on my laptop. but not on the PC of my colleague. It must be related to an other software that I have installed.

Hi Goswin and Steve,
I had a similar problem a few months ago with the Enter key but with the latest SR of Rhino 5 64-bit I can’t reproduce it anymore on Windows 8 or Windows 7.

Hi Goswin- I had this happen today for the first time- I found that closing and reopening the Python editor (that was the only thing open as far as external editors goes) may have fixed it- if you see this again, please try that; if it does not help, please try, in the Python editor, Tools > Reset script engine. We can’t tell yet which of these two actions sorted out the problem and who knows when we will see it again…

-Pascal

Hi, I have the same problem, but in my case it happens even when I just run the script. Did you find any solution? If you know how to fix it, please share the knowledge - it gets really annoying. Neither reseting the script nor reopening Python editor helps.

I have no solution yet. Don’t even know what caused this bug to appear on some Pc and on others not. Did you install any new other software before this bug came up.

Thanks Goswin, I didn’t use Python scripts on this particular machine before, so i don’t know how was it earlier. I also have Visual Studio installed, so this might actually be the reason…

Same error for me. I do not know exactly what makes the ‘Esc’ , “Enter” and ‘Del’ keys stop working, it was not at the first use of the editor in my case. And in my case the only thing that made it go away was to close and reopen Rhino. I also have visual studio, but i’m not sure this is the reason.

I just tried it again. I borrowed a laptop at work. It has a lot of apps installed. But as expected Rhino (SR5) is working fine.
Now, after I installed VS 2012 Express Web. Bang !! the Bug is back ! (Still it might have to do with something else …)

I have this bug too and it is not only enter and escape, but also the tab key and Delete key are affected. It happens after using EditScript or EditPythonScript, but also when using Grasshopper. I seems that if one of these plugins is used, after focusing back to Rhino Window, the keyboard stays in ‘Textmode’ (enter becoming linefeed, Delete becoming the forward delete key in text, and tab becoming a textual tab)

Hi Gijs, i spoke with Steve Baer about it, he is still not able to reproduce this bug. Are you able to tell under which circumstances and when it first came up ? my current suspicion is that it might have to do not only with VS but also some enterprise level security software running in the background. like McAfee.

I also have this on one of my laptops - I started lifting several keys off thinking there was an underlying problem with the keyboard.

Keith

1 Like

Keith, what is different on this laptop from your other Laptops, how did it first come up?

I cannot think of any differences other than It was my main computer - and was first noted on the 19th of October.

Keith

I’ve found one way to reproduce it on my system (win 7 64, rhino 5 64)

start editscript --> still nothing wrong
hit F1 to open Rhinoscript help

now Esc Enter Delete and Tab are no longer working as expected

I can’t reproduce it in safe mode however.

I am also getting this problem when using the RhinoScript Editor and/or Grasshopper. The behaviour though is fairly random and will occasionally ‘fix’ itself giving me back the ability to use ENTER, ESC and the right mouse button.
I was teaching a class yesterday in Grasshopper and the problem also occurred one some other laptops. These laptops are fairly similar builds (all DELL’s built by my companies IT dept) though they do not all contain the same software.
None of the methods described above will give me control back of the ENTER & ESC keystrokes. I was wondering if there is a fix available or definitive way to get back the keystrokes?
Many thanks,
Toby