Raytracing render stops

Hello, I’m new in Rhino and this is my first question.
The raytracing (Cycles) render stops when I switch to another app. Is there a way to keep Rhino calculating in background ?

Hey @Frankypop

Are you saying that the Raytraced viewport mode stops calculating when switched away?

Yes, sorry if not clear, I’m French

I mean after launching the raytraced mode in the viewport. It stops after a short while if I go working on another app, then continues automatically coming back to Rhino. So I must watch it processing… if I don’t wan’t to go back to Rhino each 30 sec just to keep it calculating the picture.

Interesting. I don’t see that happening here with Rhino 6SR25. What Rhino version are you using - maybe run the Rhino command _SystemInfo and paste the textual output here.

(Thank you for answering)
Rhino 6 SR25 2020-4-23 (Public Build, 6.25.20114.03572, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Evaluation, version 2020-04-23
License details: Stand-Alone
Expires on: 2020-08-04

Apple Intel 64-bit macOS Version 10.14.6 (assemblage 18G1012) (Physical RAM: 16Gb)
Mac Model Identifier: iMac18,2
Machine name: iMac
Language: fr-FR (MacOS default)

AMD Radeon Pro 560 OpenGL Engine (OpenGL ver:4.1 ATI-2.11.21)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 560
Displays: iMac (217dpi 2x)

Graphics processors
Radeon Pro 560 (4 GB)
iMac (2048 x 1152)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Broadcom: Magic Keyboard with Numeric Keypad
Broadcom: Magic Mouse 2

Third party kernel extensions
at.obdev.nke.LittleSnitch (5210) 0BEBCAD5-9FC2-35B4-A87D-08B14BCB15F5

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.25.20114.1002

We are using the same SR. Nothing really stands out from your _SystemInfo, so I am not sure what is going on.

@Frankypop how are you determining the raytracing stops while being switched to another app?

Because I can hear my fan stopping.
Thanks Nathan. Reading that you didn’t have the same problem although you work in the same conditions, I looked deeper and found:
It does keep rendering, BUT ONLY if I don’t work with maximized windows. With a maximized window, OSX create a new desktop, and Rhino don’t seems to be compatible with OSX multiple desktops : it’s not switching apps that is a problem, it’s switching desktops. And it’s a very big problem for me as I always work full screen.

Hmm, interesting. Because I have to frequently look into the debugger and for other output I hardly ever work in fullscreen with Rhino. I’ll try fullscreen and see what happens today.

… I’m wrong. Forcing the apps to get full screen without create a new desktop (using option + green button) doesn’t solve the problem, so in the end it’s not a question of desktops but a question of window sizes.
Rhino maximized and partially covered with a not full screen other app (example Safari), so, without changing desktop : the viewport will stop rendering in 60 sec IF the Safari window is covering the viewport and even if you can still see the Rhino menus around. Move slightly your Safari window just to show some pixels of the viewport, even without clicking in Rhino… and the rendering resumes… and will stop again in 60 sec if you move your Safari window backwards to fully cover the viewport… It’s insane !

More insane : reduce your Rhino just by a few pixels so that it isn’t full screen anymore, and try the same : the viewport rendering won’t stop even if fully covered by the Safari window this time, even if you cover the whole Rhino window, but EXCEPT if your Safari window is full screen…

I think we can call it a bug.

Just a FYI: Cycles doesn’t do any intelligent checking of a viewport being active or not, visible or not. It just renders until the requested sample count is reached.

At least now that I just tested it rendering completed a full 100 samples in 1m21s while being in the background after having been maximized with the option+zoom method. What I did notice was that the vp wasn’t fully refreshed after coming back, but clicking on the word (Cycles) in the HUD fixes that.

I just am running a second test where I request 250 samples in the viewport. And after 4 minutes switching back has the viewport still rendering as expected. Full render completed at 5m42

What do you have set as the rendering device? (Click on that (Cycles) word in the hub to see what is currently being used:


My mistake is maybe not to request any samples quantity ? how do you do this please ?

Rhinoceros > Preferences > Cycles

By default the sample count is set to 1000. No need to specifically request anything. But since you’re rendering on the CPU I’m not sure why that would stop after a while - unless the 1000 count is reached. (or whatever the sample count is you have set).

Nothing to do at first glance, but…I found
I checked everything, indeed the number of samples doesn’t change anything : I coudn’t have a rendering running in background more than 60sec if there were not some pixels of the viewport visible beside the window I’d switched to… but it changed when I closed the two left and right menus (tools, etc.) for a “full page” viewport.
So I retried after reopening the two menus. And then it worked also like that. Strange.
I guess I had changed something in the menus, probably enlarged them a little for French translations (often longer), I don’t know, but obviously something linked to the menus was disturbing Cycles.

Thanks to you I’ve kept on searching, otherwise I would have let go, very deceived, so thanks a lot Nathan !

Great to hear you found something that works for you.

I have a hard time imagining what it is you had and what you did. Maybe you could take a couple of screenshots and annotate them, highlight areas that you think were involved and how you changed them? It’d help in understanding what happened, and maybe we could uncover the bug.

Hi, in the end what had “worked” on one file, doesn’t work each time on others, but often.
I’m just having the same bug today on a new file : Cycles stops while I’m working in another app, same desktop, and restarts just when I uncover a bit the viewport (without clicking on the Rhino window).
I did the same : closed the two side menus, then reopened them, then Cycles restarts and then allows me to work in other apps without stopping this time.
When everything works, listening to my fan, I can hear that it decreases about about each 60 sec, then restarts immediately, it lets me think that Cycles stops briefly then keeps on calculating. And so on about each 60sec period. But when it doesn’t, after the first 60 sec period, the fan stops, and the rendering as well. If I have a look at Rhino, I can see that Cycles has stopped, but it immediately restarts (not from the beginning, continuing the rendering), but it stops again 60 sec later if I have switched on another app.
What I call the “side menus” :
Capture d’écran 2020-05-28 à 16.49.39 Capture d’écran 2020-05-28 à 16.49.50