Empty Rhino is very resource intensive

No need.
The effect is also seen a Desktop PC.

1 Like

I don’t see that on the Radeon I use for display adapter:

  1. FireFox only unminimized app (apart from GPU-Z)
  2. FireFox minimized
  3. Start Rhino 6SR8, then let idle - but still visible, not minimized

I’ll see if I get different behaviour on the Intel GPU and the Nvidia GPU tomorrow when I am in the office again.

1 Like

Also interesting is that the 1500MHz is not the maximum.
When I start an OpenGL game, the core clock is much higher:
image

Could Rhino to use such clock rates too?

GPU without Rhino

vs.

Rhino Version 6 SR8, launched, idle, minimized

GPU load is 0% yet temp rises 8deg?
I guess this is reason for laptop fans going on…

I tried again:
Restarted my notebook (left screenshot), then started Rhino, closed it after a few seconds and started Rhino again (right screenshot).
The results are similiar to my previous post. The GPU temperature rises 8°C as soon as Rhino is launched (empty new doc, no activity)

.

I see about what you see with my p4000.

@BoinB, @Charles, @Holo, All -

Jeff has been digging into this today and what he found, and it worked here as well, is that this setting, Power management mode, in the NVidia control panel:

needs to be set as in the image: NVidia driver-controlled.

If you can try this and report back that would be helpful - thanks.

-Pascal

6 Likes

@pascal

Cool! (in both senses ) )
I added Rhino to the Programs list and set the corresponding option, but my alternatives are slightly different.
The default was Prefer Maximum Performance. So high frequencies was understandable.

And after a short peak at Rhino start now the frequencies are at base low level.

Works like a charm! Thank You!

Ok, that works.
We hand over the control to the NVidia driver.

Does this mean, that Rhino controls the Power Mode?
If so, Rhino should use the adaptive mode as default.

So that we don’t have to touch the Nvidia settings.

@pascal
Thank you! Excellent!

Does this need to be set everytime Rhino updated?

No… Rhino has no idea about NVidia’s profile settings, nor does the installer… Now, updating the NVidia drivers may require you to redo this change, I’m not 100% sure profiles remain consistent across driver installs, but I would hope they would be.

NVidia ships a Rhino profile with their Quadro drivers and not thier GeForce drivers…so my guess is that Quadro drivers have a higher chance of stepping on any profile changes…However, I will be discussing this change with NVidia, as I’m not sure why it was set the way it was… It’s not something McNeel requested in its profile…my guess is that Rhino’s profile just got copied from some other CAD product profile, and then tweaked with our requested changes, but any/all other settings didn’t get set to their defaults…but that’s purely speculation.

-J

Hey Charles,

Nope, Rhino doesn’t control any of the profile settings… Making it the default, which is “Use global setting”, means that if you change the Global power management setting to something else, then you’ll be right back to the same problem…only my guess is that now all programs will exhibit this problem… IMO, the best solution is to find a group of settings that work perfectly for Rhino, and then lock them down inside a custom profile… Which is what we have done with NVidia and their Quadro drivers…Unfortunately, they don’t allow this for GeForce since we are not a “gaming company”, so you’re left to whatever the defaults are on GeForce installations, and are forced to create your own custom profile for Rhino(.exe).

Thanks,
-Jeff

All,

I’m curious if this also fixes your “fans spinning up” problem? It seems very related, but it’s possible this is just another problem found and has overshadowed the original problem mentioned in this thread…

Does starting Rhino and letting it stand idle still cause the fans to spin up?

Thanks,
-Jeff

My fans-problem is solved since i changed the nvidia settings. Thanks!

Just a wild guess: The NVidia driver considers Rhino as a game and therefore switches on the high performance mode by itself.
If this should be true, then there must be a reason why it is so with Rhino and not with Photoshop etc.

Fan is quiet for my XPS9650 with GTX1050, but battery drain seems a bit fast.

Also, GPU seems to think Rhino is still up and running even if Rhino is exited.

Anyone else see this problem?

----->Pls ignore the GPU thinking Rhino is still up, was ok after reboot of windows

It really isn’t as complicated as that… The drivers aren’t looking at specific vendor applications and making any kind of intelligent decisions…

What happens is that when an application creates a graphics context for the first time, it is then when the drivers get loaded into that application’s process space… During the loading of the drivers, they take a look at the process in which they are loading, and then look up in the their profile dictionary to see if there is a profile entry for that specific executable (.exe)… If the drivers can’t find a profile entry, the defaults are used, otherwise the found profile settings are used. If an application never creates a graphics context, then this process is never done. If PhotoShop uses shaders for any of its filtering (which it does), then I would expect some kind of context to be created, but it may not create that context until you actually filter something for the first time…

However, what you probably aren’t aware of are “hidden profiles” … NVidia can create profiles that you can and will never see… This is mostly done by request of the ISV… Adobe may have requested that any specific profile settings that exist, be hidden and locked down so that users cannot change them…or as I said above, simply starting PhotoShop isn’t enough to get a graphics context created…whereas starting Rhino, it’s the first thing that is needed to be able to see anything.

-J

What makes you think the GPU thinks Rhino is running? What makes you think Rhino has anything to do with this if Rhino is not running? First thing I would do is bring up the task manager and see if Rhino has indeed shutdown…you may have a zombie Rhino running for some reason.

-J

The nvidia task manager? A small icon that shows up if any program is using nvidia gpu was showing rhino as running program even after closing all windows of rhino.
But, after reboot of windows, seems to be working fine now. Yup, should have checked task manager before rebooting.