Emergency Save Rhino 6

Hello everyone,

Our daughter is studying architecture au UWaterloo.

I’m asking a question on her behalf.

She got the message: Emergency Save… We tried different ways to fix this problem. I looked in previous posts, and nothing seems to work or they are old threads. She uncheked Vray in options, and it was temporarely fix.

Is there a cure to this problem? She is panicking right now.

The other option that I read, is to reset Rhino. The only thing is, she is concerned about losing all of her Enscape materials that are embedded in her rhino files.

Hope this can be fixed…

Thanks in advance…

Hi Roger,

Resolving IT problems is hard at the best of times, but trying to do so through an intermediary (presumably not co-located) will be nigh on impossible.

The best start point will be for your daughter to post directly, because there are likely to be a lot of questions to answer.


Hi Jeremy,

Ok… I will give her the message right now.

Make sure she has the latest version of V-Ray which is supposed to have fixed the crashes. ‘Resetting’ Rhino (running a 'Repair" via Windows/Programs) will not change anything in the files themselves - it only reinstalls/repairs the program itself, files are untouched. Any materials stored in those files will still be there.

Enscape might also be causing the problem…

She should run SystemInfo in Rhino and post the results here… with as much info as possible on when and where the crashes occur.

Hi there,

My name is Julia, I am the one having these issues my dad is describing : )

I no longer have a Vray license so I have disabled Vray in my plugins which initially helped, however the problem happened again. My Enscape is up to date, i just installed the latest version this past week. I will run SystemInfo now. Should I run it in a new file or in any file I have open?

New file will be fine. Is there any consistency to when these crashes occur?

I have noticed that they often happen when I have enscape open and in Rhino I access NamedViews

Before the named views can even open the file freezes and the little blue loading circle appears, then a few minutes later the “Rhino 6 ran out of memory…” appears.

I will run SystemInfo now

Also of note, I have had the issue with files that I worth with directly on my desktop as well as on my external harddrive, it has not been specific to file location.

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Educational, build 2021-08-10
License details: Stand-Alone

Windows 10.0.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: MSI

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro T2000 (NVidia) Memory: 4GB, Driver date: 12-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.09
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-31-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2020 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Users\freck\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.21349.1646
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

First, I guess I would try updating your NVidia video driver - it’s over a year old. Not sure that will help, but it’s worth a try. You should get the driver directly from the NVidia downloads site.

I would also try temporarily disabling RhinoCAM if you don’t need it - probably not the cause of the crashes either, but just to be on the safe side.

I know you need Enscape for your stuff, but if the above steps don’t fix the problem, the other thing is to try disabling it temporarily and see if the crashes stop. If that is the case, you are probably going to need to contact them for support.

You might perhaps also download the eval version of Rhino V7 and see if anything works better than V6 without crashing. Just be careful to always have a copy of your files saved as V6 in case you decide a V7 upgrade won’t help or is not in the cards.

Okay I will try updating my NVidia drivers - Thought I had done that more recently but I guess not! Also will try disabling RhinoCAM since I do not need it at the moment either. Hopefully I won’t have to disable Enscape since all I will be doing for the next days and weeks is rendering!

Thank you so much for your help! I will give an update if there are any other issues again throughout the day.

There are no crash reports associated with this email address.
If Rhino is crashing, and the crash reported comes up (Cartoon Rhino with a deflated beach ball), add your email address, describe what you were attempting to do when Rhino crashed, AND SEND IT IN!

Then we can have a look and perhaps pinpoint the cause, suggesting a fix or work-around.

I agree with @Helvetosaur. If that was my system, I’d update the Intel and Nvidia GPU drivers.

Rhino wasn’t exactly crashing, I’ve had rhino crash before and have had to send in a crash report but this is not the same thing. “Rhino 6 ran out of memory” pops up and creates a Rhino Emergency Save file, and says that the existing file should only be used as a last resort.

Okay, that is different.

Another thing to try would be to disable All Plug-ins that do not ship with Rhino, close and restart Rhino, then do whatever it is that’s likely to cause the problem.
If the problem goes away, re-enable one of the plug-ins, restart, and try again until you can identify which plug-in is causing the problem.

Good luck

I have tried many of the suggestions, and have tried once again to simply open NamedView on the file that had the issue and the same thing happened. I have updated my drivers, RhinoCAM was already disabled. This time I noticed in the command bar : "2022.02.27 15:24:12.1713 -5:00 [HotKeyHandler] | WARN | Could not claim hotkeys. Another CAD process is unresponsive.

I’m not sure what other plug-ins to disable as a next attempt.

Did you try disabling Enscape?

So what you’re saying is that Rhino’s not actually crashing per se, it’s running out of memory?

Correct, this is what pops up:
However in my task manager there is no indication that rhino is actually using a high amount of memory.

I have not tried disabling Enscape since it is what I use to render, however I will try disabling in the enabling it once again?

Well it means that it’s about to ask for a bunch of memory. So this may or may not be a bug per se. Maybe there’s a geometry error in the model that’s causing the polygon count to go to the moon.

Please try disabling Enscape, this has to be narrowed down, you can’t just hope that’s not the problem. I see that your 4GB video card only meets the minimum requirements for Enscape, so it may be it’s running out of VRAM or (an issue I had with iRray) you don’t have enough windows virtual memory being demanded as a cache for it.

Hi Julia,

Does this happen in one specific file or in every file where you use named views?
Does it happen the first time you use named views or only after you have used the feature several times?

Is there a way to possibly find any complex geometry or error? Like how Sel___ works?

I am attempting to disable enscape and will try to access NamedView again afterwards.