Embedded files folder

EXACTLY! That’s why you link and not embed files! :wink: :grin:

You are missing the point. We link to files. If the files do not exist on the system where the Rhino file has been opened, we unpack them there.

AND embed at the same time, with no option for the user to opt out of embedding.

But ok, we’re going around in circles now, so I’ll stop and just silently pray that RH-58249 will be implemented soon! :slight_smile:

(A common use case for me is that I create a small part in Rhino, and want to do a rendered view with an imported environment, and suddenly the file is 7mb large instead of a few hundred kilobytes).

Just don’t check “Save Textures” when saving the file… that’s “opting out”.

Does an environment count as a texture? Also, when you just hit “save” in the menu, I’m guessing you always get “save textures” by default? I can’t keep doing “save as” and unchecking a box all the time. And I’d have to teach everyone who uses Rhino here at work to do the same, and someone will forget!

(Oh, god, I’ve been over this before… in this very topic even! RH-58249 RH-58249 RH-58249) :slight_smile:

I don’t think so - once you uncheck it I think it stays unchecked… In any case mine is off by default here.

Hi guys,

I’m really glad this thread has been resurrected as these embedded files folders are annoying. They sometimes appear in random places and many times the textures within them are incomplete or not as expecetd).

I’m starting from the following position:

  1. The 3dm file will not be opened on any other computer.
  2. Textures used in the 3dm file are located in one of three places:
  • V-Ray’s materials folder (eg. C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\library\Materials\Ground\maps\Soil_A_Diff.jpg);
  • my material library (eg. C:\Users\Hayden\Documents\HM\EDUCATION\CAD LIBRARY\TEXTURES\concrete\concrete 01 6,144x6,144 300d 14,028k\concrete 01.0 diffuse.jpg);
  • or in a textures folder asoociated with another 3dm file that is linked into the main 3dm model (eg. C:\Users\Hayden\Documents\HM\EDUCATION\CAD LIBRARY\3DM\People\females\sportswear 01.4 1m 99,812f (3) 22,932k\textures\Female, Sportswear 01.4 diffuse.jpg)

I just want to clarify two points please. Whenever I save the 3dm file I am prompted to make a few choices:

  1. Following on from @Helvetosaur point, if I uncheck ‘save textures’ will Rhinora stop creating these embedded files folders? I always leave it checked for fear I will loose all my textures the next time I open the file. What does ‘save textures’ actually do? (Sorry this may be obvious to some but please explain to me like I’m a four-year-old).
  2. I also get the following message, “You are attempting to embed xxxMB of support files. Are you sure you really want to do this?” I usually check ‘no’ thinking it will keep the file size low. If I check ‘yes’ will Rhinora stop creating these embedded files folders? What does ‘embedding the support files’ actually do? (Again, sorry, four-year-old again…).

TIA
H

Yes, but it only affects the current 3dm. The “Save textures” checkbox is a document property, not a global option.

It saves image files used by materials, textures, and environments in the 3dm file.

(Base on my test.)
If you choose No, all image files will be linked. The image files already embedded will be removed from the 3dm and return to be linked.

No, when the 3dm is opened, the embedded files folder appears because Rhino has to extract embedded images before loading them.

Thanks for the reply @KelvinC.

Think the best way forward for me is to uncheck save textures so the embedded files folders aren’t created.

BW

1 Like

Hey!

I have a problem similiar to the ones in this thread. I have copied blocks from one file to another and apparently rhino embedded the textures here: C:\Users\USERNAME\AppData\Local\Temp\Unpacked Files
and now it seems windows cleared this folder (because of temp folder?). Is there a way to prevent this from happening again, i.e tell Rhino not to “embedd” textures from copied/pasted blocks in a temp folder that will be deleted?

Why was the textures put in a temp folder from the beginning and not an embedded folder as usual?

I hope I’m making sense, I’m in a bit of a stressful position right now.

Hello - so the scenario is, you have blocks (linked or embedded?) that use textures in one file, and you copy/paste an instance of the block to a second file, in which that texture does not exist, correct? And on reopening, at some later date, the second file, the textures are not there… do I have that right?

-Pascal

Exactly, the textures were there for both files until today. My guess is that Windows cleared the temp folder when we went into december.

The blocks are embedded in the file where the textures are missing. I could just replace the blocks or the textures, which will take some time, but no biggie. What I’m asking is how can I prevent this from happening again, i.e not letting Rhino store textures in that temp folder when I copy objects from file to file?

RH-58249 is fixed in the latest Rhino 7 Service Release Candidate

1 Like

Fantastic! Looking forward to testing it. Where will I be able to find this in the Rhino Options? In the Files category, I’m guessing.

Hi Robert -

Those are settings in the Rhino Options > Advanced section:

-wim

1 Like