Element Parameter Not Collecting Data

I tried recreating the HumanUI interface from this Rhino.Inside. Revit youtube tutorial: How to Use Parameters in Revit through Grasshopper (4 of 5) - YouTube starting at time: 2:55.

I recreated this script exactly as it is shown but my Element Parameter is not collecting any sheet data. If I pull out the panel data from my element query we can clearly see revit sheet data though.

I found the achieved version of this script here: rhino.inside-revit/getting-input-human-ui.zip at 1.x · mcneel/rhino.inside-revit · GitHub and it seems to be working fine and looks almost exactly like my recreation. The only differences is the Element Parameter seems to be black. I have never seen a grasshopper component look like this before.

Any idea why this old script might work and why mine doesn’t? Many thanks for the help!

Here is my recreation:
Human interface for revit.gh (18.8 KB)

In your script, the names of the parameters are “drawn” and “created” while in the original example they are “Drawn By” and “Checked By”. Make sure that these parameters that you wrote exist in your Revit file.

vs

Thank you for your response. I actually tried this but the newer Element Parameter will not accept this phrasing. I think because it has a space in it. When I type it in as exactly “Created By:” it throws an error saying “parameter collected some invalid data”. This phrasing does, for some reason, work with the archived Element Parameter.

I used used “create” just as a placeholder to test the element input

Revit Parameter name can not contain any of these characters:

\ : { } | ; < > ? ` ~

or any of the non-printable characters.
We should improve the error message :slight_smile:

“Created By”, not “Created By:”

So rephrasing with out the semicolon does not throw an error but the main issue is the Element Parameter is not collecting any sheet data.

I think this issue has something to do with that specific old Element Parameter component. Is it somehow a special component because it appears black?

I also used the updated version of Element Query component. I copied that old version of the component back into my new script and fed it into the new Element Parameter and it still doesn’t collect sheet data. Both the old and new Element Query hold the same data they just have different ports.

Hard to tell if you are getting the right Elements or the correct Parameter.

There are several ways to get a sheet parameter.

This is the recommended way.

Thank you Japhy, I had to download all the latest updates to get that latest Query Sheets but it all seems to be working now.

1 Like

Human interface for revit.gh (13.1 KB)

Here is the completed file, just because I am a completionist