EditPtOn Lagging


#1

Recently when using EditPtOn command Rhino has been lagging irritably slowly. Does anyone have any thought on what could be causing this? Thank you.


(John Brock) #2

We will need a specific example and full description.

Edit Points are “cooked up” at the time of editing. They are not part of the object definition, so I suspect there is something odd about your curves but without an example, it is impossible to know.


#3

I have a closed curve of a profile that has a pretty good amount of detail to it. When first using the EditPtOn command the computer will lag for sometimes up to 30 seconds until the points show up and then when trying to move a single point I can wait sometime for up to 30 seconds for Rhino to respond.

At first I thought it could be an issue with either my graphics card Nvidia Quadro K2000D but I’ve made sure i’m up to date and using the recommended settings. In addition It doesn’t seem to be stressing the processor or using much memory.


#4

Here’s a screen shot of it that is more helpful and specific.


(John Brock) #5

We need a 3dm file with the curve in it.


#6

I’ve been noticing that it is happening with only a few curves like this one but not all.

Portrait Sample.3dm (75.9 KB)


(John Brock) #7

It takes about 10 seconds here to generate the Edit Points. It looks like there about 800.
I suspect you are mistaken about your graphics card drivers and settings.

Have a look at this:
http://wiki.mcneel.com/rhino/nvidiainfo

Make sure you’re running 340.66 and have changed the two settings in the Nvidia Control Panel tool.


#8

My settings should be like this right? This was also my first thought.

I’ve noticed it is only some of the curves not all. I’m thinking bed geometry. Rebuilding the curves doesn’t seem to work either. I’ve also noticed that some curves aren’t even able to generate edit points.


#9

Now that I’ve been drastically reducing the point count by rebuilding curves non-uniformly I’ve noticed that most curves I’m having issue with are very densely populated with points. I’m not sure how this happened, but it seems to be working so far.