Edge softening doesn't work


#1

Hi there,

I’m trying to sort out a jewelry model - ring - for printing but whenever I try to use the command ApplyEdgeSoftening, it says “37.1% of the edges were not softened because the softening radius is too large.” The result is a 0.1 edge which isn’t ideal.

Is there another program I could use to make the model a little less sharp? I can’t print until I do this…

Cheers!


(David Eränen) #2

Hi jhar!

Would it be possible for you to attach the model here so that I can try it out? If you want you can also send it to me by email. Also - what is the softening radius you are inputting?

-David


#3

Radius is 0.1

It’s attached, but I’ll only leave it up for a while just in case.

Thanks a lot!


#4

Hi @jhar

You’ve got two very skinny surfaces at the sides and they seem to mess up edge softening. If you delete them (and the front and back of the ring) and then match the remaining surfaces, join the whole thing up and use cap to close it again, the ring “softens” just fine - see attached (shown here with 0.25mm).

HTH, Jakob


#5

AFAIK _ApplyEdgeSoftening only gives you softer edges in render. The geometry is really unchanged. Export that model to print and the edges will still be sharp.

You can check by exporting your ring to STL from Rhino and then importing the STL file back in.


#6

ExtractRenderMesh :wink:


#7

You can use “extractrendermesh” to extract the softened mesh, clean it up (if needed) and then export that as STL :smile:

@Keith1634 You beat me to it!


#8

@Keith1634

awesome :slight_smile:


(David Eränen) #9

sochin is correct, the Edge Softening effect is only applied to the render mesh, not the original object. If you want the render mesh - then the ExtractRenderMesh command is what you want. However, you’ll find that the edges aren’t as soft as you’d expect from looking at the viewport, since the roundness of the edges are mostly an illusion caused by the normals.

Edit: I got beaten to this by 2 people. I need to up my game. :smiley:


#10

Hi Normand could you tell me how you identified and removed the problematic surfaces? I couldn’t seem to find them or delete them… Also could you please remove your attachment? I’ve downloaded it already, much appreciated!


#11

Hi all, thanks for your advice. Is there a plugin or program I can export a model to and get a more realistic softening? I see what was said about the mesh quality, it’s a bit rough…


#12

You can tweak the render mesh to be as fine as you like. Go to Document Properties>Mesh.


#13

@jhar Have a look at the workflow @mcramblet describes in this thread. Might give you some ideas on how to adopt that workflow to what you need. HTH


#14

I ran this through the Rhino-ZBrush-TSplines-Rhino workflow and roughly guessed at the settings to get a similar look. This was a 3 minute process, trying to get it exact would take more time. Things that are organic tend to be more forgiving if there are slight variances in the process. I haven’t used this method on precision work.


des001_ZB_TS_Workflow.3dm (2.7 MB)


#15

jhar-

Just curious, did the file I posted work for what you needed?