Draw Order Curves Still Not Working RH6

Is anyone else having problems with draw order working with curves in RH6? I never remember it working 100% of the time, but recently draw order has been inconsistent at best. I’ve tried updating and rolling back GPU drivers, cleardraworder command, project to cplane, none of which make any difference.

Are there any workarounds or fixes I’m missing? I tried scouring the forums but didn’t find anything promising.


System Info:
Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: Justin Trudeau ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-HQIP7IJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 3-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.67

Secondary graphics devices.
NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 3-17-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

1 Like

Hello - as far as I know it is working in general - please post an example if you have a case that does not…



I’ll post an example sometime today next time I encounter the issue.



I just sent you the file.

Thanks very much.

No @jtrudeau, you are not missing anything.
Its 2020 already, and draw order is still buggy :–/