Draw order only works in wireframe mode! why?


currently in Rhino 6 latest build, I can only see the correct draw order it set on objects in wireframe mode.

If I switch to any other mode the order of lines hatches etc is lost which is really annoying.

I believe this was working different at some point before.

Can you confirm and/or clarify if this is an intended behavior?


Hi Daniel - that is certainly not expected behavior as far as I know. Is this consistent for you, even in a simple test file?


yes, consistent and in any even so simple file:

here all objects with cleared draw order:



here hatch and black rectangle with “bringToFront”:


file attached!
drawOrder.3dm (29.3 KB)

Hi Daniel… thanks, looks correct here… I guess, let’s have a look at the output from the SystemInfo command…


here we go:

Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Educational, build 2020-01-28
License details: Cloud Zoo. In use by: Daniel ()

Windows 7 SP1 (Physical RAM: 48Gb)
Machine name: KRAKEN

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-29-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\ColorPicker (336da4ab-03d3-42ca-b1fb-313bfd4c1157)\2019.2.15.811\ColorPicker.rhp “ColorPicker”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Next Limit\Maxwell for Rhino\maxwell_rhino.rhp “Maxwell for Rhino”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.2.19.478\SectionTools.rhp “SectionTools”

Hi Daniel - if you have not, can you please try reverting one or more of the ‘non-working’ modes to defaults?


Hi Pascal,

thanks, yes, I tried with shaded and it fixed it.

But I can’t do that with all my custom created modes… any suggestion what could be done to fix these without resetting?

Hi Daniel - can you post or send me an ini file with a non-working mode? (Options > View > Dispay Modes > Export)


sure, for example:
FlipMode.ini (11.5 KB)

Hi Daniel - thanks - I see the problem here and I have not yet pinned down the culprit setting…


thanks for checking… I guess that can be tedious, but I hope some display pipeline programmer can give hints where to look at…

I think ambient occlusion breaks it.

*shadows, to be precise