Draw order broken for hatches

HI,

i can not assign draw order to hatches successfully in Rhino 6, latest update.
pretty frustrating, this has been quite reliable in the past.

When I set a draw order and close/save the document and reopen the display will show the correct draw order.
So it seems there is an issue with restoring the correct order within the viewport.

regards,
Daniel

Hi Daniel,
do you have a file you can share that is showing problems on your system?
Also, run the SystemInfo command in Rhino and paste the result here.

I do , but can’t share in public.

can you please give me a email or such?

thnx,
D.

You can upload files here and use wim@mcneel.com as recipient.
https://www.rhino3d.com/upload

thanks, i uploaded the file.

As I mentioned in the upload comment, also the lineweights of hatches are not displayed correctly.
sometimes it also fails for lines/curves but I have no idea what is the cause of this.

Rhino 6 SR7 2018-7-29 (Rhino 6, 6.7.18210.11281, Git hash:master @ f815aae129dfe2008152736625ca2dbd0036b29a)
Licence type: Educational, build 2018-07-29
License details: Cloud Zoo. In use by: Daniel ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-963L5LS

GeForce GTX 965M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.08)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-19-2017
Driver Version: 23.21.13.8808
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
e

You could start with updating your GPU driver, it’s good practice anyway:
https://www.geforce.com/drivers/results/137272

-Willem

@wim, i see problems here too. The display order seems to work only in Wireframe display mode for me after reopening a file.

For the linewidths it would be good if _PrintDisplay state could be saved within the document, along with the setting used for _Thickness.

_
c.

Hi Clement - got the wish at least -

https://mcneel.myjetbrains.com/youtrack/issue/RH-48102

I see the draw order problem in non-wireframe views as well.
https://mcneel.myjetbrains.com/youtrack/issue/RH-48110

thanks,

-Pascal

1 Like

Hi Pascal,

in deed the hatch draw order looks correct in wireframe mode, but the draw order of line objects remains wrong.

try:

two hatches above each other and some lines over both hatches.
bring one hatch to the front with “bringToFront”, it will be drawn on top fine
then select the line objects and “bringToFront”, they will remain below the hatch

regards,
Daniel

Hi Daniel,
I tried to reproduce the issue with the line display but was unable to.
I added notes to the bug report that Pascal filed and this is something that will need to be looked at thoroughly.

HI Wim,

thanks for taking a look… it might be somehow related to the document as well.

in the file I sent you, you might want to try with these objects:
get the green hatch on top and then try to get the black hatch and the surrounding lines on top by using “BringToFront”, can’t get it to work here!

In that file, this is the start point:

I then bring the green hatch to the front:

And then bring the black hatch and lines to the front:

The draw order is still correct after closing Rhino and opening the file again.
We see that something is going on, but it’s not easy to reproduce consistently.

alright, well… I thought we should give it a shot :wink:

when I do it here this is the result:

1 Like

Hello,
I have the same probleme with a big file where hatches are overlapping and I can’t figure out a way of bringing some curves in front of those hatches. Have there been any update since?
thanks
Quentin

There are no updates, no. The issue that is logged is hard to reproduce. If you have a file in which you can reproduce the issue consistently, we would very much like that file.

A first thing to try, though, is to make sure that you wipe out any draw order before trying to set it again - use ClearDrawOrder for that.

@q.andreotti, @wim,

Did anyone ever sort this out? I’ve had this issue for months, I’ve updated my graphics card many times in hopes the next one would fix this issue.

Thanks,
JRT

Rhino 6 SR17 2019-7-8 (Rhino 6, 6.17.19189.16411, Git hash:master @ cf56edd2ae6f54f60e146e5c7b3fb2f75e4fe114)
License type: Commercial, build 2019-07-08
License details: Cloud Zoo. In use by: Justin Trudeau ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-HQIP7IJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 5-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.86

Secondary graphics devices.
NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 5-22-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-22-2019
Driver Version: 26.21.14.3086
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

Hi Justin, that issue is still open. If you have repeatable steps to make this happen we would like you to send a 3dm file with a description of the necessary steps.
-wim