Document Properties/Rhino Options Commands Don't Work

v6_display

#1

I have installed a Rhino 6 upgrade on my desktop and laptop and am using the zoo for my single commercial licence on the two machines. Rhino 6 was installed on the Desktop first and runs normally. For some reason, I cannot make changes to the document properties (Annotation, Grid Settings) or Rhino Options (Appearance, Colors) on the second install on the laptop. Is this a licensing issue or something else in the way I’m using the two installs?
Any help would be appreciated.


(Pascal Golay) #2

Hello - I don’t think this has anything to do with licensing - can you tell me the exact symptoms, blow by blow? You open DucumentProperties > Grid page to make a change say, and what happens, exactly?

-Pascal


#3

With both an attempt to make a background color change (I usually use a black background) and a grid settings change (I usually turn the grid off), I open the document properties window to make the change. When I make the change in the document properties window, I can see the effect of the change on the screen behind the document properties window, i.e. the background changes to black or the grid lines disappear. However, when I close the document properties window, the changes I have made revert back to the defaults - grey background, grid lines on. Also, if I open any older drawings that have the settings I normally use with this install, they are displayed with the default settings. Again, this is only with the install on my laptop. The install in my desktop (workstation) works normally. both machines have normally functioning copies of Rhino 5 on them. both machines have plenty of ram and video processing horsepower to run the program.
Thanks for the help
K


(Wim Dekeyser) #4

Have you tried running Rhino as administrator once?


#5

I tried - running as administrator does not fix the issue.


(Ben Haycraft) #6

The only way I can replicate what you are describing is by clicking the X in the top right of the Document Properties window. If I click OK at the bottom, the changes are applied when the window is closed. Just so we are on the same page, you are clicking OK correct?


#7

I believe this may be the problem. However, I am unable to see the entire Document Properties widow on the screen of my laptop, and I am not able to move or re-size the window in such a way as to be able to see the OK button at the bottom of the window. On my desktop, my screen is much larger and the entire window is visible, however, I noticed that the controls for moving and re-sizing the window do not work on that machine either. One exception: on both installations, the Document Properties window can be moved by dragging with the mouse pointer at the top bar of the window. This still does not help with the installation on the laptop as I would have to drag the top of the window off of the screen in order to see the bottom of the window, which is not possible. Is there a setting which is locking the size of this window?


(Nathan 'jesterKing' Letwory) #8

You probably can get to the OK button using TAB. Selecting top-left entry Document Properties needs only one TAB press to highlight the OK button, after which you can press enter. Figure out on your desktop how many presses you need to get there from the section you are making changes in.

How high is your laptop screen in pixels? The Options dialog has some minimum height.


#9

As it turns out, the OK button is highlighted by default at that step of the process so hitting Enter after hitting OK in the color change window completes the process. This takes care of my problem, however, it would be a great help if the window size could be edited, or, even better, adapted automatically to the size of the screen so that all controls would be visible under any circumstances. I’m sure there are a lot of people running this program on laptops out there.
For reference, both my desktop monitor and laptop screen are 1920 x 1080 resolution. The Document Properties window measures 8 1/4" tall on my desktop monitor. The usable screen height on my Lenovo Thinkpad Yoga 14 running Windows 10 is 6 5/8". This means that there’s a substantial amount of the window that I cant see on my laptop. I can guess that, if the window is a fixed number of pixels, this problem would be even worse on a smaller laptop or one with lower resolution. I really don’t think it would be a problem to have to scroll through a few more of the options in a size-adjusting window.
I highly recommend that McNeel look into making this change.


(Nathan 'jesterKing' Letwory) #10

This should be ample height for the options dialog to fit, I also run on that resolution.

Do you have scaling set for your laptop?


#11

This I don’t know. Is this a Rhino setting or something I need to investigate on my laptop?


#12

Found the setting - this fixed the problem - didn’t know the setting existed until now. thanks for hangin in there with me all!