DocProperties>Mesh page: render meshes regenerated even if Cancel is pressed

I am noticing that if I go to Doc Properties > Mesh just to check the current mesh settings - first it shows me the “Render mesh quality” page with Jagged, Smooth and Custom; if Custom is checked I hit the "Details button to see the custom settings. If I then hit the Cancel button without having changed anything, it still regenerates the display meshes for all visible objects - I see “Creating meshes… Press Esc to cancel” in the command line and if the meshes are dense, it takes a few seconds before finishing.

IMO, this is hooked up incorrectly, hitting the Cancel button should not do anything if I have not changed the setttings.

Hi Mitch - thanks, I’ll check it.
Can you verify? Here, I do not see any mesh created if I cancel, only on OK…

-Pascal

Hi Pascal,

It is happening at least with the file posted in this thread:

As that file seems to have ‘problem’ objects, perhaps it’s just the file…

Wait, wrong button pressed… here’s the right video:

Nope, not just that file, here is a file with 1K cubes and a custom mesh setting:

1KCubes.zip (1.1 MB)

Also happens with just “smooth and slower” mesh settings - at least I thought it did - can’t reproduce now.

I’m just going to check in a minute, but try with extrusions and non-extrusions…

-Pascal

The file posted above (1K cubes) is 100% polysurfaces.

durn.

It appears to be happening only when one has a custom mesh set, but it actually does not seem to matter which settings are used…

Hi Mitch - Here, using your file, once custom mesh is set with an OK (remeshes), reopening the dialog and cancelling does not churn out new meshes…

-Pascal

So what’s wrong with my installation??? :astonished:

Yeah… just wondering about Bongo - seems unlikely, but what I’d normally say is, you know, disable non-default plug-ins, close, relaunch, and see…

-Pascal

OK, wow, I went to disable Bongo, just into Options>Plug-ins (not Mesh settings), disabled it and OK, then I got the meshes being recreated… And no, after a Rhino restart, disabling Bongo didn’t help. It looks like every time the Options dialog is closed, it re-meshes if I hit OK. No matter which page it was on. But not if I hit Cancel, remeshing only happens if I am on the Mesh page. :exploding_head: