Rhino regenerating render meshes on every Options panel close with "Custom" mesh settings

Hello,

I’ve been seeing this problem recently and can confirm still persists with the latest daily build : every time we open Tools > Options panel and close it (regardless of any changes made there) Rhino recreates all render meshes in the file, which often takes a long time on complex models and is a major work disruption. Can anyone else see this happening?

EDIT: this only happens when hitting “OK”, when hitting cancel or closing the window there is no problem.

thanks,

–jarek

Hi Jarek - thanks, I’ll check it.

I do not see this here so far - simple test - … are there likely suspects among your plug-ins? Does the meshing register in the command history (presumably yes…)?

-Pascal

hi Pascal,

How do I make SafeMode allow to have Rendered mode? In wireframe only I can’t try to reproduce this… Is there a way to force safe mode to load only some plugins? I guess I need RhinoRender that ships with Rhino enabled.

And yes, “Creating Render Meshes” prints to the command line…

thanks,

–jarek

Hi Jarek - if you do not have lots of plug-ins that seem like candidates, you can just disable them in Options > Plug-ins page, then close and reopen Rhino - see if the problem is gone, then re-enable and load them one or two at a time to see if you can find the bad guy.

-Pascal

Hi Pascal,

I disabled all filtered by “that Do Not ship with Rhino”, 10 or so, but the problem still persists…
(and Safe Mode doesnt help since there are no Render Meshes becasue I only have Wireframe mode)

Any other ideas?
Also, to make sure we are looking at the same thing, my build is:
7.9.21193.11001, 2021-07-12

I also made sufficiently complex mesh so I see when it gets regenerated every time, but since it prints to command line a simple box test would do, too…

-j

Hi Jarek - can you post a list of those plug-ins? I know it seems unlikely but I still suspect a plug-in for now. Can you also start a new file for your box test using ‘No template’, just to eliminate that possibility (user data or something)?

-Pascal

Neither do I…

Hi Pascal,

here is the list:
image

So I unloaded them all, then started with No Template and the problem is gone.
From an empty template file the problem still shows.
So I went as saved the Template file with “Save no plugin data” but the problem still happens…

My guess is Lumion, but I will try one by one.
Just dont know why template with no plugin data would still kick that in : /

-j

Hi Jarek - that is odd… does your normal template have any geometry in it? Or layouts? Grasping at straws…

-Pascal

Nope, just layers and 1 material, plus Sun and Skylight enabled…
Let me test various combinations here and if not result I will post the template here.
Thanks for quick tips!

@Pascal, ok that’s weird. Somehow even with all plugins loaded there is no problem, unless I use my template files, which I have been using for a long time.

Here is the template file, as soon as I make a box in it, the behavior described above starts.
Can you see anything like that on your end with this file?
Inches_V7.3dm (1.9 MB)

It’s weird that it is 2 MB, I saved it with no plugin data and it’s an empty file. Not sure what’s wrong with it…

but same happens with this older template file from V6 (small size file):
Inches.3dm (45.4 KB)

Hi Jarek - thanks, I see it with both of those files… I’ll see what I can find out.

-Pascal

1 Like

The file size difference could be that I enabled Uncompressed Save in Advanced options (V7 template) which was not the case in V6 template. I don’t think that’s the culprit just a guess why the file size is much bigger. The problem probably lies elsewhere in the file, not the compression type.

-j

Hi @Pascal,

I might have found a culprit - this happens even on “No Template” new file, as soon as the Mesh in Document Properties is set to Custom… Jagged and Faster or Smooth and Slower don’t cause this, but Custom always does. We always work with Custom and the template files I sent here also have that on.
Can you possibly see this on your end, not only with my templates, but in general?
If I turn off Custom in my templates all works fine, too.
Wild guess - something wrong with the new SubD Meshing Parameter for Raytracing added in V7?

–jarek

Can you see it if you set your document mesh to “Custom” ?

Hi @Pascal,

bumping this one again, still can’t figure out what is wrong and why Custom meshing mode always forces remesh with options panel (see above messages). It’s getting in the way with heavy scenes but I ran out of ideas what else to try, unless this is some bug. Anything else to try?

thanks,

–jarek

Hi Jarek - thanks,I’ll try to reproduce this with Custom. (I do not have any bright ideas but if I can reproduce that would be step 1)

Yep, got it - thanks.
RH-65017 Options causes remeshing

-Pascal

Hi Pascal, thanks for confirming that.
It became a major performance issue here, hope it can get fixed soon!

–jarek