Display Problem - curves in front of solids/surfaces


#1

I have a persistent very frustrating problem that line (curve) objects behind solid surfaces or polysurfaces show up through the solids in shaded display and render display modes (especially if there are multiple curves). Please see screen shot of space frame showing through roof. I am on a Dell Precision M4700 laptop with 16GB RAM, 64 bit, Intel Core i7 and Nvidia Quadro K2000M video card.

Any help would be much appreciated. Something is very wrong. Thanks.


#2

Think I figure it out, cool.

Go to the right panel for objects properties/layers/properties. Go to the display tab. Then choose shaded display from the dropdown menu on top of the panel. Then on the bottom, theres a box called "x-ray all wires"
you likely have this checked.



#3

I think you have enabled antialiasing in options>view>openGL


(Pascal Golay) #4

Hi Matt - try running ClearDrawOrder - does that help?

-Pascal


#5

Thanks to all. Problem solved per Pascal’s suggestion. ClearDrawOrder fixed it perfectly. Thank you Pascal.


#6

Brilliant! That was all it was. Thanks so much.

Matthew

Matthew Winkelstein AIA, LEED AP
Design Director - West Coast Studio

William McDonough + Partners
177 Post Street, Suite 920
San Francisco, CA 94108

C: +1(415) 690-5315


#7

Hello,

I am having a similar problem (see attached screenshot). I have a model in which some solid objects are coincident with one another. Edges from the solids behind are showing through the relatively thin solid in front. I’m running with a intel 400 graphics card which i know isn’t recommended but everything else runs fine.

The model is fairly large compared to these parts and if I export these smaller parts into a new empty model space the problem disappears. Similarly if I invert-hide everything in the full model except these parts the problem disappears. I’m doing all my modeling in rendered mode. So invert hide solves it but i can’t do that all the time. I’m pulling views into a layout for annotating for a build manual.

Updated rhino, nothing
Graphics card drivers up to date
Clear draw order… nothing
Playing with anti aliasing… nothing
fiddling with open GL settings… nothing.
Restoring render mode defaults… nothing

The problem exists in shaded mode as well and only presents itself at certain shallow-ish viewing angles.

Any ideas?


(Pascal Golay) #8

Hi Moose- for this, try testZBiasFactor (smaller)

-Pascal


#9

Fantastic!!! I watched them disappear like magic. You have my thanks!


#10

The testzbiasfactor workaround has worked for a while but i’ve run across another case where even this isn’t solving the problem. It solves it at first but the lines re-appear right after i hit CTRL-P and then there they are in my printout. I’m wondering what’s really going on here.

On an unrelated issue, i’ve got a layout space of a fairly large model with about a dozen detail windows and after a while the layout space becomes very slow and laggy to copy things and zoom in and out of and pan in. The 3d model space is very snappy no issues there just the layout space.


#11

It seems to reset the zbiasfactor (whatever that is) back to 1 right before it runs the print command. The model displays visually correctly with a value of say 0.1.

Other observations. The lines that show through are 0.25" behind the surface and show through with a value of 1 for the zbias. The total extent of the model is about 2400" x 5000" x 300"

If I export the offending surface to a new model the problem is gone. If I then import into the orignial model very near the origin the problem is back. BUT if I invert/hide everything but the problem then the phantom lines are gone.

So for now when I need to print a layout view i have to invert hide the rest of the model, take my print, then show all again.


(Pascal Golay) #12

Thanks, I’ll check this.

I do not see this here- what is the print driver? A real printer, or pdf, or?

-Pascal


#13

Print command meaning CTRL-P usually to a jpeg “image file” but it displays the same no matter what i’m printing to.

I also have run into the issue of phantom surfaces mentioned on anther thread these surfaces are see through at some angles and solid like they should be at other angles of view ironically the fix for that mentioned in another thread was to increase the z bias factor. I found that using the “flip” command on those surface knocked them back to “normal” i.e. no see through anymore from any angles.

Still using my invert hide trick for now when needed.


#14

Apologies for reviving an older post. I had the same problem as 3dmoose above, and your comment about testZBiasFactor (and setting it to “Less”) worked beautifully - however, it seems to reset whenever I restart Rhino. Is there a way to get this setting to “stick” across instances of running the program?

Thanks,
August


(John Brock) #15

Nope. It’s a “Session” setting.
You’ll need to set it when you need it.

Maybe make a command button…


(Pascal Golay) #16

Hi August - add this to your startup commands (Options > General ) -

_NoEcho _TestZBiasFactor _Less _Enter

But please try the WIP witjout this command - is it any better there?

-Pascal


#17

Thanks for the response - not in a position to test the settings currently but I will shortly. However I wanted to say I’ve noticed the problem only seems to occur when I am in “Parallel” view. Normal perspective projections seem to not have the issue.


(TYC) #18

Literally a life saver!! Thanks man!